Electric Brewing Supply 30A BCS Giveaway!


Home Brew Forums > Home Brewing Beer > DIY Projects > is it my freezer or thermostat?
Reply
 
LinkBack Thread Tools
Old 04-06-2013, 06:33 PM   #1
mendozer
Feedback Score: 1 reviews
Recipes 
 
Join Date: Nov 2009
Location: Seattle, WA
Posts: 585
Liked 4 Times on 4 Posts

Default is it my freezer or thermostat?

recently my keezer hasn't been cold. I have a thermometer at my collar which shows 60. Typically it shows 45 and my thermostat bulb is at the bottom set to 38-40. I can hear the compressor running though.

is there a way to test if my thermostat is malfunctioning? It is in a vial with water as well, so it's not set up improperly.

I would really HATE to have my freezer be pooping out on me after all the hard work i put in.

thanks

__________________
mendozer is offline
 
Reply With Quote Quick reply to this message
Old 04-07-2013, 09:21 PM   #2
mendozer
Feedback Score: 1 reviews
Recipes 
 
Join Date: Nov 2009
Location: Seattle, WA
Posts: 585
Liked 4 Times on 4 Posts

Default

I switched the freezer's plug from the johnson controls plug to a regular outlet. It's been working the whole time since then, about 4 hours. It's still in the low 50s in there, with 48 on the lower inside wall being the coldest. How much longer should I see results in?

Any people in the trade know how much it costs to pump some more freon in there?

__________________
mendozer is offline
 
Reply With Quote Quick reply to this message
Old 04-07-2013, 10:57 PM   #3
mblanks2
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2013
Location: , The State of Confusion!
Posts: 434
Liked 31 Times on 30 Posts
Likes Given: 36

Default

Depending on the type of freon and the company you call out, it may be more cost effective to look at a newer unit. Lowes/Home Depot deep freeze type units. What you describe definitely sounds like a refrigerant problem. Service call $85 - $100, then refrigerant charging $50 -$150 depending on type and company.
Do you have any friends that are in the HVACR business?

__________________
mblanks2 is offline
 
Reply With Quote Quick reply to this message
Old 04-08-2013, 03:09 AM   #4
Wobbly
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2013
Posts: 12
Liked 1 Times on 1 Posts
Likes Given: 1

Default

Here is an easy thing to try. Unplug the keezer for a minimum of 24 hours, 48 is better. Then plug it back in and try again.
Some (most) freezers with a compressor will go into a defrost cycle a few times a day to eliminate build up of frost on the evaporator coils. If the defrost cycle isn't working the freezer will not cool properly do to ice build up on the coils.
When you plug the unit back in check the temperature after a few hours and if all is well the problem is the defrost circuit/system. (The problem will reoccur
over time)
You can also check to make sure the gasket on the lid is sealing well and that the condenser coils are clean.

Hope this helps, good luck

__________________
Wobbly is offline
 
Reply With Quote Quick reply to this message
Old 04-08-2013, 04:14 AM   #5
mendozer
Feedback Score: 1 reviews
Recipes 
 
Join Date: Nov 2009
Location: Seattle, WA
Posts: 585
Liked 4 Times on 4 Posts

Default

i cleaned off the condenser coils a bit today. I'll try that unplug resetting method

__________________
mendozer is offline
 
Reply With Quote Quick reply to this message
Old 04-08-2013, 03:08 PM   #6
Wobbly
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2013
Posts: 12
Liked 1 Times on 1 Posts
Likes Given: 1

Default

Quote:
Originally Posted by mendozer View Post
i cleaned off the condenser coils a bit today. I'll try that unplug resetting method
Just to be clear you are not resetting anything by unplugging the unit, what it does is to allow the the evaporator coils to de-ice.

If it works OK for awhile after being plugged back in and then starts to fail again, you can be fairly confident that the freon level is ok and that the problem is in the defrost circuit. More on that after later
__________________
Wobbly is offline
 
Reply With Quote Quick reply to this message
Old 04-08-2013, 11:55 PM   #7
mendozer
Feedback Score: 1 reviews
Recipes 
 
Join Date: Nov 2009
Location: Seattle, WA
Posts: 585
Liked 4 Times on 4 Posts

Default

is it a cyclical thing? i haven't had any issues since last March when I got it. If it's a once yearly unplugging, I'm ok with that

__________________
mendozer is offline
 
Reply With Quote Quick reply to this message
Old 04-09-2013, 12:10 AM   #8
day_trippr
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2011
Location: Stow, MA
Posts: 10,591
Liked 1283 Times on 1034 Posts

Default

Quote:
Originally Posted by Wobbly View Post
[...]If it works OK for awhile after being plugged back in and then starts to fail again, you can be fairly confident that the freon level is ok and that the problem is in the defrost circuit. More on that after later
Chest freezers have defrost circuits?

Cheers!
__________________
day_trippr is offline
 
Reply With Quote Quick reply to this message
Old 04-09-2013, 03:40 PM   #9
Wobbly
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2013
Posts: 12
Liked 1 Times on 1 Posts
Likes Given: 1

Default

Quote:
Originally Posted by day_trippr View Post
Chest freezers have defrost circuits?

Cheers!
No I think most if not all do not, I was thinking more of a refrigerator when I first replied, but that being said if the evap. coils are iced up, defrosting the unit will help.
Definitely worth trying before spending money to repair the unit.
__________________
Wobbly is offline
 
Reply With Quote Quick reply to this message
Old 04-11-2013, 03:55 AM   #10
mendozer
Feedback Score: 1 reviews
Recipes 
 
Join Date: Nov 2009
Location: Seattle, WA
Posts: 585
Liked 4 Times on 4 Posts

Default

ok i did the 48 hour rest. I plugged it in for 4 hours directly to outlet and it got reasonably cold, but not freezing. Then i unplugged it and switched it to the thermostat. The compressor didn't run, indicating that it was at 38d, which it certainly didn't feel like.
Now a day later, my beer is pouring out at 53d. uck!

So maybe it's low on freon?

__________________
mendozer is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
stand up freezer / what thermostat? spam DIY Projects 3 03-30-2012 05:29 AM
freezer thermostat suggestions? karbinator Equipment/Sanitation 7 07-18-2011 02:17 AM
CHI freezer thermostat? Cpt_Kirks Equipment/Sanitation 1 10-07-2010 03:40 PM
Freezer thermostat stoneman Bottling/Kegging 1 05-07-2009 02:27 PM