Spike Brewing 12.5 Conical Fermenter Giveaway!

Home Brew Forums > Home Brewing Beer > Beginners Beer Brewing Forum > Can't Put my Finger on the Problem

Reply
 
LinkBack Thread Tools
Old 10-21-2011, 06:01 PM   #11
birvine
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2010
Location: Cochrane, Ontario, CANADA
Posts: 1,512
Liked 10 Times on 10 Posts
Likes Given: 4

Default

Quote:
Originally Posted by Whippy View Post
As I was trying to study the flavour, my intuition told me that it had something to do with the hops. What kind of hops do you brew with, birvine? Do you typically use pelletized or whole hops? Do you grow your own?
I have packages of pellet hops from two different suppliers as well as homegrown. Usually I use my homegrown only as bittering hops. I just went to check the batches but there seems to be no pattern to this.

However, I also checked the grains I used - I am now starting to wonder if those two AG batches used a rancid 2-row grain. Or, if there was a problem with them in the MT. Two batches is not necessarily a pattern, but some obvious commonalities I see are AG, a grain and dry-hopping.

One was with new dry yeast and the other was washed yeast.

There must be some silly little thing that I'm doing.

Brent
__________________
Manager & Head Brewer
Swan Lane Brewery
birvine is offline
 
Reply With Quote Quick reply to this message
Old 10-21-2011, 06:03 PM   #12
birvine
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2010
Location: Cochrane, Ontario, CANADA
Posts: 1,512
Liked 10 Times on 10 Posts
Likes Given: 4

Default

I'm kegging an AG Arrogant Bastard cousin (I slightly changed the crystal malts so I call mine Arrogant Buster) tonight so I am going to really take note of the flavour and smell (as much as I can) as I rack and maybe even chill a glass of the flat beer to see what it tastes like.

Brent

__________________
Manager & Head Brewer
Swan Lane Brewery
birvine is offline
 
Reply With Quote Quick reply to this message
Old 10-21-2011, 06:30 PM   #13
Whippy
Feedback Score: 0 reviews
Recipes 
 
Join Date: Aug 2010
Location: Irmo, South Carolina, USA
Posts: 616
Liked 30 Times on 27 Posts
Likes Given: 108

Default

I'll be interested to hear more, Brent.

__________________

Two weeks to ferment, two more in the kegs
but in just one night it was drained to the dregs

Whippy is offline
 
Reply With Quote Quick reply to this message
Old 10-21-2011, 07:29 PM   #14
jamnw
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2010
Location: tn
Posts: 95
Liked 1 Times on 1 Posts

Default

My friend was getting some off flavors in his bottles. Turned out the bottling spigot was contaminated. Replaced it and I believe he is ok now.

__________________
jamnw is offline
 
Reply With Quote Quick reply to this message
Old 10-21-2011, 07:58 PM   #15
birvine
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2010
Location: Cochrane, Ontario, CANADA
Posts: 1,512
Liked 10 Times on 10 Posts
Likes Given: 4

Default

I bottle with a racking tube and sanitize each time, plus, I have used it in batches that turned out fine.

Brent

__________________
Manager & Head Brewer
Swan Lane Brewery
birvine is offline
 
Reply With Quote Quick reply to this message
Old 10-21-2011, 10:34 PM   #16
birvine
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2010
Location: Cochrane, Ontario, CANADA
Posts: 1,512
Liked 10 Times on 10 Posts
Likes Given: 4

Default

I just kegged my Arrogant Buster brew and I could smell it AGAIN!!! Grrrrr!!

In a very foul mood I cleaned the carboy and it almost has a burning rubber smell to it.

Brent

__________________
Manager & Head Brewer
Swan Lane Brewery
birvine is offline
 
Reply With Quote Quick reply to this message
Old 10-22-2011, 11:39 PM   #17
Yambor44
HBT_LIFETIMESUPPORTER.png
Feedback Score: 0 reviews
 
Yambor44's Avatar
Recipes 
 
Join Date: Nov 2008
Location: Ocala Florida
Posts: 1,951
Liked 43 Times on 28 Posts
Likes Given: 5

Default

Quote:
Originally Posted by birvine View Post
I just kegged my Arrogant Buster brew and I could smell it AGAIN!!! Grrrrr!!

In a very foul mood I cleaned the carboy and it almost has a burning rubber smell to it.

Brent
I feel for ya Brent. I have the same issue off and on with a Hefe flavor and aroma of my beer. Has happened in an IPA clones as well as PA's. I thought I had mine nailed down to reusing yeast that wasn't properly "washed". Another theory is that when I use my tap water, there were some I forgot to use my Camden tablets with (to rid chloramine).

Could yours be one of the same?
__________________
Yambor44 is offline
 
Reply With Quote Quick reply to this message
Old 10-22-2011, 11:40 PM   #18
Overpanic
Feedback Score: 0 reviews
Recipes 
 
Join Date: Sep 2011
Location: Los Angeles, CA
Posts: 7
Likes Given: 2

Default

If you haven't changed anything in your brewing setup, and previous brews have turned out fine, then oxygenation is unlikely to be the culprit here.

From what you're describing, I'd be more concerned that somewhere along your brewing/bottling pathway, there is a source of contamination.

You say that you've been brewing for a while; are you still using the same plastic brewing/bottling bucket? I would check it for scratches that could harbor infection, and consider replacing it altogether.

I also would switch to bottled water for brewing (for now), so that you can at least rule out your water as the source of the problem, and limit the variables here.

You may also want to consider changing out all of your siphoning tubing, if it's at all old, as that can also harbor infection.

You didn't mention what method you're using for cooling, but take a good hard look at your equipment - especially if you're using a counter-flow or plate chiller, the latter being especially hard to clean and sanitize from what I'm told.

Good luck! I hope you narrow down the cause of the problem soon so you can get back to worry-free brewing!

__________________
Overpanic is offline
 
Reply With Quote Quick reply to this message
Old 10-23-2011, 10:34 AM   #19
birvine
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2010
Location: Cochrane, Ontario, CANADA
Posts: 1,512
Liked 10 Times on 10 Posts
Likes Given: 4

Default

Overpanic:

I think I have narrowed it to an infected batch from which I used its yeast for two other batches - all three of these were the bad ones. I dumped the rest of the washed yeast from that batch!

That being said, you're right about some of my equipment. I am due to replace it and will. After this third batch I want to solve this!

Brent

__________________
Manager & Head Brewer
Swan Lane Brewery
birvine is offline
 
Reply With Quote Quick reply to this message
Old 10-24-2011, 07:28 PM   #20
Scandalous
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jul 2010
Location: Sun Prairie
Posts: 29
Liked 2 Times on 2 Posts
Likes Given: 1

Default

You may be on to something. If you use a yeast for a batch that has something wrong with it, i.e. it's tired or infected, when you wash and repitch, you are literally selecting yeast for those bad flavors. Also, chorination and chloramines can cause off flavors. Chlorination is typically not a problem (it gasses off), unless you are using bleach as a cleaner. Chloramine won't gas off. My recommendation, In your next batch, use glass for fermentation, fresh yeast, new hoses and pbw/straight-A as a cleanser and star san for your sanitizer.

__________________
Scandalous is offline
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
BIg Problem...Help pls Stalldaworld Beginners Beer Brewing Forum 15 04-12-2011 01:16 AM
Low OG a problem? EmGeeTee Beginners Beer Brewing Forum 13 03-18-2011 05:54 PM
Keg Problem outdoors76 Beginners Beer Brewing Forum 3 10-28-2010 10:22 AM
Possible problem... Danny013 Beginners Beer Brewing Forum 9 09-05-2007 01:37 AM
I think I have a problem USFBull Beginners Beer Brewing Forum 20 04-13-2007 03:15 PM