Ss Brewing Technologies Giveaway!

Home Brew Forums > Home Brewing Beer > Beginners Beer Brewing Forum > Band Aid Smell/Taste
Reply
 
LinkBack Thread Tools
Old 09-26-2012, 02:30 AM   #1
Jaehnig
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2012
Posts: 225
Liked 8 Times on 8 Posts

Default Band Aid Smell/Taste

First batch just bottled. Smells and tastes like band aids and veggies (not good ones). This is probably a water issue or fermenting temp issue or both.

Can this taste be remedied? Longer bottle conditioning times?

__________________

V/R,
BrewTech

Jaehnig is offline
 
Reply With Quote Quick reply to this message
Old 09-26-2012, 02:32 AM   #2
FastAndy
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2010
Location: Reno, NV
Posts: 1,057
Liked 152 Times on 120 Posts
Likes Given: 19

Default

Sounds like it could be DMS in the beer. Did your grain bill have a lot of pilsner in it? If you an post the recipe and process that will help us narrow down the problem.

__________________
FastAndy is online now
 
Reply With Quote Quick reply to this message
Old 09-26-2012, 02:33 AM   #3
dbrewski
This is my User Title
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
dbrewski's Avatar
Recipes 
 
Join Date: Oct 2011
Location: Indeterminate
Posts: 1,020
Liked 52 Times on 46 Posts
Likes Given: 36

Default

Read this:

http://www.howtobrew.com/section4/chapter21-2.html

__________________
dbrewski is offline
 
Reply With Quote Quick reply to this message
Old 09-26-2012, 02:47 AM   #4
Jaehnig
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2012
Posts: 225
Liked 8 Times on 8 Posts

Default

It was actually just an amber ale extract kit that I added roasted pumpkin during the boil and some spices during the last few minutes to try to turn it into pumpkin ale. So quite simple. It could very well be DMS though. Hard for me to know that smell because this is my first beer and am newer.

Used water from tap. Only boiled 2.5 gallons (should have tried more but worried stove was too weak to boil a larger volume). Dry yeast. Had a yeast starter which worked incredibly well. Star San sanitizer. 10 days primary. 18 days secondary. Just bottled last Friday. Very very strong smell though.

Fermentation temps were at about 72 degrees for almost the entire process (little warmer at first maybe 76 until evened out)

__________________

V/R,
BrewTech

Jaehnig is offline
 
Reply With Quote Quick reply to this message
Old 09-26-2012, 02:52 AM   #5
JonGrafto
Feedback Score: 2 reviews
Recipes 
 
Join Date: Jan 2012
Location: Central Part of the State..., WI
Posts: 1,565
Liked 95 Times on 74 Posts
Likes Given: 11

Default

Did you have the lid on when you were boiling? That could cause it.

__________________
Quote:
Originally Posted by Whattawort View Post
Looks like a zombie took a dump in your bucket after a night of binging on hot arse and cabbage.
JonGrafto is offline
 
Reply With Quote Quick reply to this message
Old 09-26-2012, 02:55 AM   #6
Jaehnig
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2012
Posts: 225
Liked 8 Times on 8 Posts

Default

Quote:
Originally Posted by JonGrafto
Did you have the lid on when you were boiling? That could cause it.
Only for part of it. Good portion was open boil. I plan to make fermentation chamber. Use bottled water. Keep cover off during boil.

I practiced good sanitation as well.

Can this be fixed?
__________________

V/R,
BrewTech

Jaehnig is offline
 
Reply With Quote Quick reply to this message
Old 09-26-2012, 02:55 AM   #7
FastAndy
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2010
Location: Reno, NV
Posts: 1,057
Liked 152 Times on 120 Posts
Likes Given: 19

Default

Those fermentation temps are kinda high but that usually throws off more of a fruity ester type off flavor. Did you top up with tap water or leave it to cool for a long period of time? Sounds like it maybe be an infection.

__________________
FastAndy is online now
 
Reply With Quote Quick reply to this message
Old 09-26-2012, 02:56 AM   #8
Jaehnig
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2012
Posts: 225
Liked 8 Times on 8 Posts

Default

Quote:
Originally Posted by FastAndy
Those fermentation temps are kinda high but that usually throws off more of a fruity ester type off flavor. Did you top up with tap water or leave it to cool for a long period of time? Sounds like it maybe be an infection.
Topped with tap in primary. Cooled in primary in tub of water. Was covered during this process.
__________________

V/R,
BrewTech

Jaehnig is offline
 
Reply With Quote Quick reply to this message
Old 09-26-2012, 03:00 AM   #9
FastAndy
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2010
Location: Reno, NV
Posts: 1,057
Liked 152 Times on 120 Posts
Likes Given: 19

Default

Hmm. I suppose tap water could cause an infection, seems unlikely but it does seem like its an infection of some sort. Was there much lag time between pitching an signs of fermentation? Did you take readings during fermentation (could be the exposure from a not so clean thief or hydrometer)? What are you using as a sanitizer?

__________________
FastAndy is online now
 
Reply With Quote Quick reply to this message
Old 09-26-2012, 03:02 AM   #10
dbrewski
This is my User Title
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
dbrewski's Avatar
Recipes 
 
Join Date: Oct 2011
Location: Indeterminate
Posts: 1,020
Liked 52 Times on 46 Posts
Likes Given: 36

Default

Medicinal: These flavors are often described as mediciney, Band-Aid™ like, or can be spicy like cloves. The cause are various phenols which are initially produced by the yeast. Chlorophenols result from the reaction of chlorine-based sanitizers (bleach) with phenol compounds and have very low taste thresholds. Rinsing with boiled water after sanitizing is the best way to prevent these flavors.

__________________
dbrewski is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools