Home Brew Forums > Home Brewing Beer > Beginners Beer Brewing Forum > am i drunk or is a hydrometer f-d!
Reply
 
LinkBack Thread Tools
Old 10-24-2009, 09:44 PM   #1
LSDracula
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: Chandler, AZ
Posts: 77
Liked 1 Times on 1 Posts

Default am i drunk or is a hydrometer f-d!

Just finished an ancho chile pale ale. Only used 6 pounds of light dme, 8oz honey malt, 4oz 20L crystal, 2oz ancho chiles. Thought hydrometer read 1.084 shook my head and assumed it read 1.064 still to high for the recipe.
Did I do something wrong. Its gotten to the point where the last 2 recipes I made I didn't even take an OG reading just used www.brewcalculus.com
Is it just me?

__________________
LSDracula is offline
 
Reply With Quote Quick reply to this message
Old 10-24-2009, 09:55 PM   #2
bingotem
Feedback Score: 0 reviews
Recipes 
 
Join Date: Aug 2008
Posts: 4
Default

You could put it in some distilled water and see if you get around 1.000.

__________________
bingotem is offline
 
Reply With Quote Quick reply to this message
Old 10-24-2009, 09:59 PM   #3
JVD_X
HBT_LIFETIMESUPPORTER.png
Feedback Score: 4 reviews
 
JVD_X's Avatar
Recipes 
 
Join Date: Jan 2008
Location: Gainesville, Virginia
Posts: 1,492
Liked 3 Times on 3 Posts

Default

Quote:
Originally Posted by bingotem View Post
You could put it in some distilled water and see if you get around 1.000.
I pointed this out in another thread and I got jumped on. I mean for folks that spend thousands of dollars coming up with a thousand contraptions to accomplish the same thing that a simple infusion can do, for them to jump on my butt for even suggesting using 2 cents of distilled water for verifying a hydrometer - it was like I committed a felony or something.

Use distilled water as the previous poster pointed out.
__________________

- JVD_X

JVD_X is offline
 
Reply With Quote Quick reply to this message
Old 10-24-2009, 10:08 PM   #4
Benjibbad
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2009
Location: Riverview, FL
Posts: 312
Default

If the hydro read is correct it could be the wort wasn't completely mixed

__________________

Primary 1: Cedrella Vanilla Porter
Primary 2: Empty
Primary 3: Empty
Primary 4: Coastal Red
Primary 5: Empty
Secondary 1: Empty
Secondary 2: empty
Secondary 3: empty
Keg1: Cherry Lambic
Keg2: A-10 IIPA
Keg3: Crazy Cuban Monk (Cedrella infused Tripel)
Keg4: Kolsch weisen hybrid

Benjibbad is offline
 
Reply With Quote Quick reply to this message
Old 10-24-2009, 10:21 PM   #5
LSDracula
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: Chandler, AZ
Posts: 77
Liked 1 Times on 1 Posts

Default

Tested hydrometer with water... it's fine.
Shook the hell out of the primary before taking a reading.
How much mixing is enough for a partial boil extract brew?

__________________
LSDracula is offline
 
Reply With Quote Quick reply to this message
Old 10-24-2009, 10:26 PM   #6
LSDracula
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: Chandler, AZ
Posts: 77
Liked 1 Times on 1 Posts

Default

I'm tempted to get a power drill an agitator fitting. Like you you would use for mixing drywall mud or epoxy.

__________________
LSDracula is offline
 
Reply With Quote Quick reply to this message
Old 10-25-2009, 12:03 AM   #7
HillbillyDeluxe
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: 'Possum knob KY Near lexington
Posts: 663
Liked 6 Times on 5 Posts

Default

have you pitched yet?

__________________

You gonna pull them pistols, or whistle dixie?


Possum Knob Brewery and Stables
Possum Knob, KY.

HillbillyDeluxe is offline
 
Reply With Quote Quick reply to this message
Old 10-25-2009, 01:19 AM   #8
jkarp
Beer Herder
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
jkarp's Avatar
Recipes 
 
Join Date: Jun 2008
Location: Elizabeth, CO
Posts: 2,105
Liked 34 Times on 29 Posts
Likes Given: 4

Default

Positive you had enough wort in the tube? Maybe the hydrometer was bottoming out. Bubbles sticking to the hydrometer can cause significantly high readings too.

__________________
jkarp is offline
 
Reply With Quote Quick reply to this message
Old 10-25-2009, 01:34 AM   #9
JLem
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: Attleboro, MA
Posts: 3,645
Liked 171 Times on 150 Posts
Likes Given: 4

Default

Annoying question, I know, but was this a 5 gallon batch?

__________________
My Hombrewing Blog

My Beer Cellar
JLem is offline
 
Reply With Quote Quick reply to this message
Old 10-25-2009, 04:52 AM   #10
duffman2
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jun 2009
Location: Houston Texas
Posts: 608
Liked 9 Times on 5 Posts
Likes Given: 3

Default

Dude, I don't know. Just when I think I'm getting the hang of this stuff my hydrometer seems to throw me a curveball too. I just brewed yesterday and my hydro reading was 1.055 (sposed to be 1.051). So, after seeing no activity after 24+ hours I took another and......1.060!! What is going on??

I used the yeast activator from AHS for the first time. I shook the hell out of the fermenter and so far nothing!! So, you're not alone man.

I think this is just the nature of the homebrewing beast.

__________________
duffman2 is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools




Newest Threads

LATEST SPONSOR DEALS