Ss Brewing Technologies Giveaway!

Home Brew Forums > Home Brewing Beer > Extract Brewing > OG Issue
Reply
 
LinkBack Thread Tools
Old 06-02-2007, 02:07 AM   #1
badnaam
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2007
Posts: 41
Default OG Issue

I used the following recipe and was expecting a 1.063 OG (according to BeerSmith software), my actualy og (taken after pouring the water and wort into the fermenter and mixing them a little with a spatula) was 1.052. Why am I missing a point?

1 lb Simpsons Medium Crystal 60 L
.5 lb Digeman's Caramunich
8.5 Lbs of LME
2.5 oz of Warrior. (60 mins)

Thanks

__________________
badnaam is offline
 
Reply With Quote Quick reply to this message
Old 06-02-2007, 02:18 AM   #2
Yooper
Ale's What Cures You!
HBT_ADMIN.png
Feedback Score: 0 reviews
 
Yooper's Avatar
Recipes 
 
Join Date: Jun 2006
Location: Upper Michigan
Posts: 61,017
Liked 4451 Times on 3240 Posts
Likes Given: 866

Default

You probably didn't have the water and wort mixed well before taking a reading. The heavier wort sinks and the water rises to the top so your reading is a little light. Don't worry about it- the yeast can find those fermentables! It'll be fine.

Next time, mix well and really whip it up to aerate it (after it's cool, that is!). Mine gets a white frothy head on it, then I pitch the yeast.

__________________
Broken Leg Brewery
Giving beer a leg to stand on since 2006
Yooper is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
CO2 Issue claphamsa Bottling/Kegging 7 07-22-2009 01:39 PM
keg top issue Chris Z Bottling/Kegging 7 05-12-2009 03:36 PM
BYO issue? RonRock Beginners Beer Brewing Forum 5 01-24-2009 02:51 PM
Possible Keg Issue - How to fix? briandickens Bottling/Kegging 6 09-07-2007 01:09 PM