Kegconnection Complete Starter Kit and More Giveaway!


Home Brew Forums > Home Brewing Beer > All Grain & Partial Mash Brewing > Is it my water ?

Reply
 
LinkBack Thread Tools
Old 08-27-2009, 08:40 PM   #1
pghpi
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2009
Location: Pittsburgh, pa
Posts: 9
Default Is it my water ?

I've been brewing extract and all grain for a number of years. Recently, I moved to a new area and bought a house. A few months ago, I began to start my brewing back up and started out with a few extract batches. Everything was fine.. no problems.

However, two weeks ago I started with a few all grain brews (lager and ale)and noticed something peculiar. Both brew took exactly four days to start bubblin'. I thought that I might have had a stuck fermentation issue, but after leaving them, they took off by themselves. Now they are running like gangbusters. I already had to rack the lager and everything seems fine.

The only difference (other than the obvious) between the extract and all grain was that I used spring water for the extract and tap water for the all-grain. I consulted with a local brewer that uses the same source water than me and he never had an issue.

Is this something to be concerned with and/or is there a fix?

Thanks for any responses!!

Cheers!

Dan

__________________
pghpi is offline
 
Reply With Quote Quick reply to this message
Old 08-27-2009, 09:02 PM   #2
Snafu
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
Snafu's Avatar
Recipes 
 
Join Date: Apr 2009
Location: Richmond, VA
Posts: 1,010
Liked 15 Times on 13 Posts
Likes Given: 2

Default

Liquid Yeast? Did u use a starter?

__________________
I have vessels, some contain beer.
Snafu is offline
 
Reply With Quote Quick reply to this message
Old 08-27-2009, 09:15 PM   #3
greenbirds
HBT_SUPPORTER.png
Feedback Score: 1 reviews
Recipes 
 
Join Date: May 2008
Posts: 468
Liked 8 Times on 8 Posts
Likes Given: 1

Default

Need to know yeast type, temperatures, etc.

__________________
greenbirds is offline
 
Reply With Quote Quick reply to this message
Old 08-27-2009, 09:48 PM   #4
pghpi
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2009
Location: Pittsburgh, pa
Posts: 9
Default

I used white labs for both of them. The lager and ale were stored at appropriate temps. That's what has me confused.

__________________
pghpi is offline
 
Reply With Quote Quick reply to this message
Old 08-27-2009, 10:38 PM   #5
BigEd
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2004
Posts: 2,329
Liked 112 Times on 99 Posts
Likes Given: 15

Default

Quote:
Originally Posted by pghpi View Post
I used white labs for both of them. The lager and ale were stored at appropriate temps. That's what has me confused.
To repeat the question in an earlier post, did you make a starter? Using the so-called "pitchable" yeasts as is, especially with a lager can result in a very long lag time. Regarding your water, unless you give us the water profile ppm and your beer recipes with associated technique like mashing temps it is impossible to know if the H2O is problematic. However, I seriously doubt using the wrong water profile is somehow responsible for your extended lag time.
__________________
BigEd is offline
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mash water/sparge water ratio Philsc Beginners Beer Brewing Forum 28 06-13-2014 09:11 PM
building brewing water from reverse osmosis (RO) water Kaiser Recipes/Ingredients 7 05-11-2014 08:34 PM
IPA water recipe - adjusting high bicarbonate water conpewter Brew Science 19 10-01-2010 05:29 PM
Tankless Water Heater for Sparge water? passedpawn Equipment/Sanitation 38 06-07-2010 03:32 PM
Bottled Water Recommendations For IPA? Water Here Sucks coryforsenate Recipes/Ingredients 4 08-03-2009 07:44 PM



Newest Threads