New Giveaway - Wort Monster Conical Fermeneter!

Home Brew Forums > Home Brewing Beer > All Grain & Partial Mash Brewing > Lager yeast and FG issue




Reply
 
LinkBack Thread Tools Display Modes
Old 02-16-2010, 05:57 PM   #1
oguss0311
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2007
Location: Northern NJ, USA
Posts: 256
Liked 1 Times on 1 Posts

Default Lager yeast and FG issue

I know I could re-read everything I have ever read and likely find some answers- but the baby is sick, and so am I. Not too much time for reading.
Here is my issue.
The last two batches that I made (an Amber Lager and a Munich Dunkel) have stopped fermenting at about 1.030!(Give or take a bit) The Amber Lager had an OG of 1.050 and is using White Labs 820- which I know to be Very slow. It's grain bill was 50/50 Pils/Munich. I used a double decoction. The next had a grain bill that was 100% Minuch (OG 1.053, also a double decoction, using White Labs 830). Both are repeat recipes. The grain bill is slightly different this time- but the yeast is not. Both batches had been in healthy, beautiful looking 1 gal starters.
I left one (WL820) in the secondary, and see plenty of CO2 bubbles coming up, but not much in the way of airlock activity....And the other I repitched some yeast (Saflager...something or another) in the hopes of getting it down.
I was thinking that I might have pissed off the yeast by too sudden a temp change...But nothing I really did was that drastic. The temps have gone from pitching in the 60's, down to the high 50-s then to the fridge which has them at 52degF- which are obviously Well within their desired range.....
I feel like I must be missing something Really basic here....Like- Did I create too much Un-fermentable sugar or something? Do I have too much of- or not enough of something that the yeast need to get the job done right?
I used an O2 stone, left on for a full min- which has Always done the job.
Both decoction temps were from the low 140's to mid to 150's F.
Can those of you out there who know what I've done give me a hand?
Thanks...........
Just in case your all ponder this- I did use yeast nutrient, I am aware of how poor 100% Munuch Malt can perform- in regards to extract content and enzimatic (SP?) potential...(It work SOooo well last time!). Etc. I think I covered all the major bases.....
yup....



__________________
oguss0311 is offline
 
Reply With Quote Quick reply to this message
Old 02-16-2010, 07:56 PM   #2
menschmaschine
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jun 2007
Location: Delaware
Posts: 3,278
Liked 31 Times on 26 Posts

Default

Assuming you got good conversion during the mash... describe your decoction process. I have a feeling the answer is somewhere in there.

__________________

END TRANSMISSION

menschmaschine is offline
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options
Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible Yeast Issue . . . BrewDrinkBrew Fermentation & Yeast 2 02-10-2010 04:30 PM
yeast issue spike47 Beginners Beer Brewing Forum 6 01-23-2009 11:52 PM
Weird Lager Issue Cpt_Kirks Beginners Beer Brewing Forum 2 11-30-2008 06:30 PM
Yeast Issue backwards General Techniques 1 02-08-2007 12:54 AM
Yeast Issue (not Really) Willie3 General Techniques 12 10-30-2006 02:58 PM