Home Brew Forums

Home Brew Forums (http://www.homebrewtalk.com/forum.php)
-   All Grain & Partial Mash Brewing (http://www.homebrewtalk.com/f36/)
-   -   Garbage pail ale finished much lower than expected... (http://www.homebrewtalk.com/f36/garbage-pail-ale-finished-much-lower-than-expected-331504/)

phoenixs4r 05-27-2012 09:16 PM

Garbage pail ale finished much lower than expected...
 
We decided to take some scraps of hops left about and throw it together with some pale and smoked malt for an experiment:

22lbs pale 2 row
2 lbs smoked malt (cherry wood, if that matters)
Mash@148F
Safeale 05

OG 1.062 @ 11.5 gallons (hit the numbers perfectly) Beersmith estimates our FG at 1.10

Sat for a month cause we got busy, kegged it today, down to 1.002.

Thermometers are calibrated.

Wild bug? Shows no signs. Tastes fine. Thoughts?

idigg 05-27-2012 09:33 PM

I saw another thread here stating it went to 1.002 with us05. Weird... my batches with us05 go no lower than 1.010 even at a month in primary. Did you mash for a long time or something?

phoenixs4r 05-27-2012 09:43 PM

Quote:

Originally Posted by idigg
I saw another thread here stating it went to 1.002 with us05. Weird... my batches with us05 go no lower than 1.010 even at a month in primary. Did you mash for a long time or something?

Nope normal 60 minutes. It created a damn good summer beer I'm just worried about being able to reproduce it next year! Lol

J311gonzo 05-28-2012 01:25 AM

I have this "problem" if you want to call it that with most of my beers... and I believe its because I do not do a yeast starter... do you? I was told that I get this crazy attenuation with my ales because of this.

phoenixs4r 05-28-2012 01:26 AM

Dry yeast, rehydrated only. I do this for all my beers and don't have this issue.

b33rmug 05-28-2012 09:23 AM

I have the orange wheat from another thread in the fermenter and the US-05 took it down to 1.004. I thought it was done earlier, but it's kept going.

emjay 05-28-2012 10:03 AM

Quote:

Originally Posted by J311gonzo
I have this "problem" if you want to call it that with most of my beers... and I believe its because I do not do a yeast starter... do you? I was told that I get this crazy attenuation with my ales because of this.

You ever use 3711?

ellijo89 05-29-2012 11:55 PM

I actually just had the same problem as well. 1.05 OG, 154F mash temp, US-05. I over pitched just a touch but also didn't aerate like usual. I expected right around 10-12 FG, but checked it out of primary and it is looking to be right around 1.005. Just like yours mine tasted fine. Pretty confusing.


All times are GMT. The time now is 07:35 AM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.