Spike Brewing 12.5 Conical Fermenter Giveaway!

Home Brew Forums > Home Brewing Beer > All Grain & Partial Mash Brewing > Consistent Off-Flavor in my Centennial Blonde

Reply
 
LinkBack Thread Tools
Old 12-20-2012, 12:01 AM   #31
GotPushrods
Bearded Lagerjack
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
GotPushrods's Avatar
Recipes 
 
Join Date: Jul 2012
Location: Phoenix, AZ
Posts: 359
Liked 59 Times on 43 Posts
Likes Given: 6

Default

Quote:
Originally Posted by Guidry View Post
Ok, I know how to calibrate to the extremes, but give me some ideas on calibrating to the temps in the mashing ranges.
You just need a reference thermometer that you trust. Ideally you'll find a lab mercury or alcohol glass thermometer. But if you have a 2 or 3 digital thermometers at home that all more-or-less agree, that will work for now. A meat thermo, BBQ wireless thermo, pH probe temperature readout, whatever you have. Borrow something if you need to. A ThermaPen would be great if you know someone that has one.

Bring a pot of water to 150 according to your reference thermometer and adjust your mash tun thermometer accordingly. It may now be off at freezing and boiling, but who cares!
__________________
GotPushrods is offline
 
Reply With Quote Quick reply to this message
Old 12-20-2012, 04:45 AM   #32
Dok
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2009
Location: St Louis, Missouri
Posts: 164
Liked 8 Times on 4 Posts

Default

Quote:
Originally Posted by stpug
could this just be a "green beer" taste that will subside in a few weeks? Perhaps it shines through more so with this lighter-side beer than your others. How long will this taste persist if you leave a bottle/keg?
+1
__________________
Dok is offline
 
Reply With Quote Quick reply to this message
Old 12-20-2012, 02:51 PM   #33
afr0byte
Feedback Score: 0 reviews
Recipes 
 
Join Date: Aug 2010
Location: Vermont
Posts: 1,398
Liked 69 Times on 58 Posts
Likes Given: 48

Default

I'd wager it's almost certainly the high sodium level + high alkalinity. You shouldn't be brewing with water from a softener.

__________________
afr0byte is offline
 
Reply With Quote Quick reply to this message
Old 12-20-2012, 04:18 PM   #34
Guidry
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: Denham Springs, La
Posts: 627
Liked 29 Times on 27 Posts
Likes Given: 4

Default

We do not have a softener installed at my house. At least not one I am aware of. The water in our area is known to be soft. Taking a shower usually requires as much work to get the soap off as it does to scrub off the dirt.

__________________
Guidry is offline
 
Reply With Quote Quick reply to this message
Old 12-20-2012, 04:51 PM   #35
afr0byte
Feedback Score: 0 reviews
Recipes 
 
Join Date: Aug 2010
Location: Vermont
Posts: 1,398
Liked 69 Times on 58 Posts
Likes Given: 48

Default

Quote:
Originally Posted by Guidry View Post
We do not have a softener installed at my house. At least not one I am aware of. The water in our area is known to be soft. Taking a shower usually requires as much work to get the soap off as it does to scrub off the dirt.
That's odd looking water then. I wouldn't brew with it, personally (I'd get RO water from the grocery store.). It looks like all of the reports I've seen from softened water. Are you near the ocean? Also, regardless of the source, your alkalinity is much too high for blonde beer like this. It'd be easier to use RO.

EDIT: N/m, I see you're not near the ocean.
__________________
afr0byte is offline
 
Reply With Quote Quick reply to this message
Old 12-20-2012, 08:55 PM   #36
DagoBrewer
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2011
Posts: 121
Liked 4 Times on 3 Posts

Default

Quote:
Originally Posted by Guidry View Post
OK, I've posted my process and equipment in a separate thread as to not hijack this one. Anyone who feels like trying to help, my new distress thread is at:

http://www.homebrewtalk.com/f36/consistent-off-flavor-my-centennial-blonde-375255/#post4698398
When was the last time you took your mash tun apart and cleaned or replaced any crusty looking parts? I just had a couple batches in a row taste like what youre describing. I rebuilt my tun using all stainless parts instead of the brass stuff cuz it had some nasty stuff building up in and around the valve and rubber washers.. first batch after rebuilding it tastes back to normal again..
__________________
DagoBrewer is offline
 
Reply With Quote Quick reply to this message
Old 06-12-2013, 03:09 AM   #37
kchomebrew
HBT_SUPPORTER.png
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2011
Location: Kansas City, MO
Posts: 489
Liked 42 Times on 31 Posts
Likes Given: 1

Default

Use campden tablets to get rid of the chlorine/chloramine in your water. Add 1 to 2 tsp of gypsum to up the Ca level. That ought to do it. I ran into some of the same problems you mentioned for quite some time as the water where I am at is somewhat low in Calcium. Good luck.

__________________
kchomebrew is offline
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
BM's Centennial Blonde -> Strawberry Blonde illin8 Recipes/Ingredients 8 12-11-2013 07:21 AM
Consistent Off-Flavor after Secondary Transfer blackdogbrewer General Techniques 9 05-15-2012 09:11 PM
Odd Consistent Off Flavor stocktires General Beer Discussion 16 10-15-2011 06:18 AM
Consistent off flavor WBishop Beginners Beer Brewing Forum 25 08-03-2011 06:01 PM
Centennial Blonde/Columbus Blonde The Pol All Grain & Partial Mash Brewing 12 06-24-2008 01:14 AM