*Ss Brewing Technologies Giveaway - Enter Now!*

Home Brew Forums > Home Brewing Beer > All Grain & Partial Mash Brewing > Consistent Off-Flavor in my Centennial Blonde
Reply
 
LinkBack Thread Tools
Old 12-19-2012, 05:53 PM   #1
Guidry
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: Denham Springs, La
Posts: 628
Liked 29 Times on 27 Posts
Likes Given: 4

Default Consistent Off-Flavor in my Centennial Blonde

I am having a problem with an off flavor I keep getting in my centennial blonde brew. See the post below for details.

http://www.homebrewtalk.com/f66/cent...ml#post4697299

It was recommended that I post my brew process and equipment and maybe someone could spot a possible cause.

Here is my brew process, I can go into more detail if you see a possible problem:

1. Heat strike water in large kettle (Aluminum)
2. Heat mash tun (Rubbermaid 10 cooler style) with hot water
3. Crush grains (gap set to approx .035”)
4. Drain hot water from tun, add strike water at predetermined temp
5. Add grains while stirring. Measure temp and close lid on tun.
6. Heat sparge water (batch sparge)
7. Vorlauf and drain first runnings into SS boil kettle
8. Add sparge water and stir
9. Drain remaining volume
10. Heat to rolling boil
11. Add hops at predetermined intervals
12. Added immersion chiller at approx. 10-15mins remaining in boil time
13. Shut off flame at end of boil time
14. Chill to approx. 70 degs
15. Take starting gravity reading
16. Siphon into carboy
17. Pitch rehydrated yeast into carboy
18. Move carboy to “swamp cooler” in dark room, cover from light
19. Wait until airlock activity ceases and take gravity reading
20. 24 hrs later, repeat gravity reading until no change
21. Siphon beer to keg

My equipment is:

Heating kettle: 12gal aluminum kettle
Boil kettle: 8gal SS kettle
Mash tun: 10gal Home Depot round cooler with SS mesh braid
Fermenting vessel: 6.5 gal glass carboy
Chiller: 50' copper IC
Fermenting cooler: Igloo CUBE swamp cooler

Any ideas or questions, I'll be happy to elaborate on what I normall do.

Thanks.

__________________
Guidry is offline
 
Reply With Quote Quick reply to this message
Old 12-19-2012, 06:22 PM   #2
acefaser
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2011
Location: firestone, co
Posts: 350
Liked 17 Times on 11 Posts
Likes Given: 2

Default

You say your getting soapy & metallic flavors? All looks ok to me. Do you know your water profile? Mash PH? Whats your sanitation procedure? Starsan?
What beers do you normally brew that turn out ok?

__________________
acefaser is offline
 
Reply With Quote Quick reply to this message
Old 12-19-2012, 06:49 PM   #3
Mojzis
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2012
Location: Rochester, NY
Posts: 1,138
Liked 114 Times on 85 Posts
Likes Given: 79

Default

I have heard of taps contributing to a metallic taste. That's another area I would check.

__________________
Mojzis is online now
 
Reply With Quote Quick reply to this message
Old 12-19-2012, 06:57 PM   #4
Guidry
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: Denham Springs, La
Posts: 628
Liked 29 Times on 27 Posts
Likes Given: 4

Default

Copied from the water profile:

pH 8.5
Total Dissolved Solids (TDS) Est 200
Electrical Conductivity, mmho/cm 0.33
Cations / Anions, me/L 3.5 / 3.4ppm
Sodium, Na 80
Potassium, K < 1
Calcium, Ca < 1
Magnesium, Mg < 1
Total Hardness, CaCO3 3
Nitrate, NO3-N 0.1 (SAFE)
Sulfate, SO4-S 3
Chloride, Cl 5
Carbonate, CO3 9
Bicarbonate, HCO3 166
Total Alkalinity, CaCO3 151
"<" - Not Detected / Below Detection Limit

I have no idea on the mash pH.

This beer is the only one I have noticed this flavor with. I usually brew IPAs and stouts/porters, which I guess could hide the flavor.

__________________
Guidry is offline
 
Reply With Quote Quick reply to this message
Old 12-19-2012, 07:06 PM   #5
Guidry
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: Denham Springs, La
Posts: 628
Liked 29 Times on 27 Posts
Likes Given: 4

Default

I use an oxyclean solution for cleaning and starsan for sanitizing.

I've beent reading some of the brewing sites and it mentions that BOILING in an aluminum pot may cause metallic flavors. I do not boil in one, but I heat my strike/sparge water in one. I may heat some up tonight, let it cool and see what it tastes like.

One other idea is that I use the plain vinyl clear tubing to drain my wort from the tun to my kettle. The specs say it is ok up to 175degs and that it can be used for beverage dispensing. Could some flavor be coming from that?

@Mojzis: I tasted last night direct from the carboy/gravity sample, so no tap has entered the picture.

__________________
Guidry is offline
 
Reply With Quote Quick reply to this message
Old 12-19-2012, 07:17 PM   #6
Mojzis
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2012
Location: Rochester, NY
Posts: 1,138
Liked 114 Times on 85 Posts
Likes Given: 79

Default

I use the same tubing with no issues. I doubt its that unless you were sold a different brand then labelled. Sounds like it could be your kettle. I have heard not to use oxyclean with aluminum or chlorine with brass.

Also what shape is the kettle in? Heavily oxidized, relatively new...etc?

__________________
Mojzis is online now
 
Reply With Quote Quick reply to this message
Old 12-19-2012, 07:28 PM   #7
Guidry
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: Denham Springs, La
Posts: 628
Liked 29 Times on 27 Posts
Likes Given: 4

Default

You think it could be my kettle I use to heat the strike water? Ya think even at temps <180degs, the flavor could be produced?

Now that you mention, maybe the cleaning with oxyclean removed the oxidation from the aluminum. I remember reading somewhere how to "recondition" the aluminum....Going look for that text.

__________________
Guidry is offline
 
Reply With Quote Quick reply to this message
Old 12-19-2012, 07:32 PM   #8
CGVT
Senior Member
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
CGVT's Avatar
Recipes 
 
Join Date: Jun 2011
Location: Spanish Fort, AL
Posts: 1,580
Liked 375 Times on 247 Posts
Likes Given: 266

Default

I heat my strike water and boil my wort in an aluminum pot and have never had an issue. I don't wash the pot other than rinsing and wiping down with a nylon scrubbing pad though.

Soapy flavor may be that you aren't rinsing well enough.

Is the metallic taste astringency?

__________________

"Filled with mingled cream and amber I will drain that glass again. Such hilarious visions clamber through the chambers of my brain--Quaintest thoughts--queerest fancies come to life and fade away; Who cares how time advances? I am drinking ale today"-Edgar Alan Poe

My Keezer build: http://www.homebrewtalk.com/f51/keez...y-turn-340755/

Quote:
Originally Posted by TyTanium View Post
Do what you like, brew what you like. Don't be a tool.
CGVT is offline
 
Reply With Quote Quick reply to this message
Old 12-19-2012, 07:32 PM   #9
he-brews
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2012
Posts: 55
Liked 4 Times on 3 Posts

Default

I have pretty much the exact setup and was getting a twangy taste like that. I started using spring water instead of our home water even though I was putting the pills in it to make the water taste right and it went away when using the spring water from walmart

__________________
he-brews is offline
 
Reply With Quote Quick reply to this message
Old 12-19-2012, 07:34 PM   #10
stpug
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2012
Posts: 2,370
Liked 330 Times on 288 Posts
Likes Given: 154

Default

Could this just be a "green beer" taste that will subside in a few weeks? Perhaps it shines through more so with this lighter-side beer than your others. How long will this taste persist if you leave a bottle/keg?

__________________
stpug is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
BM's Centennial Blonde -> Strawberry Blonde illin8 Recipes/Ingredients 8 12-11-2013 07:21 AM
Consistent Off-Flavor after Secondary Transfer blackdogbrewer General Techniques 9 05-15-2012 09:11 PM
Odd Consistent Off Flavor stocktires General Beer Discussion 16 10-15-2011 06:18 AM
Consistent off flavor WBishop Beginners Beer Brewing Forum 25 08-03-2011 06:01 PM
Centennial Blonde/Columbus Blonde The Pol All Grain & Partial Mash Brewing 12 06-24-2008 01:14 AM