HBT 2014 Big Giveaway - 4/10 Re-Draw Winners Posted!

Home Brew Forums > Home Brewing Beer > Bottling/Kegging > Nothing coming out of keg




Reply
 
LinkBack Thread Tools Display Modes
Old 06-21-2009, 03:18 AM   #1
skydog4884
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2009
Location: Sioux Falls, SD
Posts: 29
Default Nothing coming out of keg

So i built a kegerator, i have been dispensing my homebrew perfectly. I bought a d style sankey coupler to put on a bud light keg (I know, i know i just dont want a bunch of random people drinking my homebrew) and i switched over the hoses. I transported the keg into the fridge, let sit for hours then tapped, let sit for an hour and tryed to dispense. Nothing comes out. I can see small co2 bubbles coming out of the top of the tap into the beer hose. Please help. I need to get this pouring. Foam pours out at like a tablespoon per minute of the tap. Thanks for your help

Skyler



__________________
skydog4884 is offline
 
Reply With Quote Quick reply to this message
Old 06-21-2009, 03:50 AM   #2
Professor Frink
Feedback Score: 0 reviews
 
Professor Frink's Avatar
Recipes 
 
Join Date: Sep 2006
Location: San Diego, CA
Posts: 3,106
Liked 12 Times on 12 Posts

Default

Are you sure you have pressure going into the keg? If there's a leak, you won't be able to dispense any either.



__________________
Primary: Cherrywood Smoked Porter
60 Minute IPA
Secondary:
On tap:Amber Ale
Milk Stout

Lagering:


http://www.lazydogbrewery.com
Professor Frink is offline
 
Reply With Quote Quick reply to this message
Old 06-21-2009, 05:04 AM   #3
skydog4884
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2009
Location: Sioux Falls, SD
Posts: 29
Default

when i take the tap off and just lower the handle without attached to a keg, it pushes out tons of co2.

__________________
skydog4884 is offline
 
Reply With Quote Quick reply to this message
Old 06-21-2009, 02:33 PM   #4
skydog4884
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2009
Location: Sioux Falls, SD
Posts: 29
Default

I figured it out. There were two little plastic balls in the coupler that i did not realize were there. i removed those, hooked the hose back up and it worked like a champ

__________________
skydog4884 is offline
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options
Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nothing much coming out of Keg? mgable Bottling/Kegging 10 08-01-2008 12:35 PM