*Ss Brewing Technologies Giveaway - Enter Now!*

Home Brew Forums > Home Brewing Beer > Bottling/Kegging > Keg frustration
Reply
 
LinkBack Thread Tools
Old 02-20-2012, 04:39 AM   #1
tackucack
Feedback Score: 0 reviews
Recipes 
 
Join Date: Sep 2010
Location: Salt Lake City
Posts: 19
Default Keg frustration

So I'm 2 years into brewing and I finally pulled the trigger on a keg setup. I bought all my fittings and lines from keg connection, and some corny's from a local brewer leaving the hobby. Built my keezer, attached the controller, and then I finally racked a porter into the first keg and plugged in the gas.

2 weeks later after a slow force carb, (too afraid to go too quick on my first batch in fear of overcarbing) I pull my first glass from my new system. PLASTIC!!! Argh it tasted terrible. I had no idea what was going wrong, and then I thought "wait, I haven't run anything through my lines yet." haha, I admit I had already been a couple beers deep at this point. So I unplugged (and continued my bottle night).

The next day I took a cleaned second keg, filled with Starsan and flushed it through the lines. After that I plugged the porter back in and took another sample. PLASTIC!!!

Now I'm getting worried, so I go to the boards and start searching. I found a ton of info and found one suggestion was to sample directly from the keg. I purged, opened it, sampled, PLASTIC!!!

So now I'm really puzzled. This beer tasted fine from primary to secondary, and secondary to keg. I'm all freaked out about chlorine now, but I used a campden(for the first time ever in this batch). My batches before and after this had no plastic flavor, so why just this batch?

Any thoughts? I'm really trying to think of anything I could have done wrong. Since kegging is new to me I'm a little in the dark, but all signs seem to point to something with this process. I changed the o-rings and used keg lube (purchased at a LHBS). I cleaned the keg with one-step since the guy I bought them from had old leftover beer sitting in it.

All these amazing stories about how awesome kegging is, and I get this on my first batch?!?

__________________
tackucack is offline
 
Reply With Quote Quick reply to this message
Old 02-20-2012, 04:54 AM   #2
SandRidgeBrewer
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2012
Posts: 11
Default

Check out my post "how can I fix my co2 flavored beer?". The title should be changed since it had nothing to do with co2 but I too just started kegging and ran into the same issue. The members here helped me resolve my concerns. Although now I am facing foamy beer but already know that it is because the line is only 3 feet long.

__________________
SandRidgeBrewer is offline
 
Reply With Quote Quick reply to this message
Old 02-20-2012, 05:06 AM   #3
Golddiggie
HBT_SUPPORTER.png
Feedback Score: 1 reviews
 
Golddiggie's Avatar
Recipes 
 
Join Date: Dec 2010
Location: Between here and there, and everywhere
Posts: 12,058
Liked 477 Times on 420 Posts
Likes Given: 266

Default

All my hoses, and most of my fittings are also from Keg Connection. I'm using either kegs from a local person that reconditions them (fully) or brand new ones from Rebel Brewer. I use 2.5 and 3 gallon kegs, so that I can fit four into my brew fridge.

I never use 'one step' in my kegs, or lines. I always do a PBW run through the lines (after completely rinsing the kegs out), followed by a clear water rinse, followed by running StarSan through the entire assembly (for that keg). No plastic flavors at all.

Since your flavor is inside the keg, I suspect the source is also there. Did you inspect both dip tubes when cleaning the keg(s) out?

I also use clean tasting water (zero other flavors in it) when I brew. Either from the filter system under my brew-buddy's sink, my own dual stage filter system under my sink, or the portable filter assembly I recently made (modified version of the BYO DIY issue model). Every water source I use has no odor or other flavors to it when you drink it plain. Hence I don't need to treat the water with anything in order to get no chlorine caused off-flavors.

According to descriptions, the flavor you're getting very well could be from chlorine in the water you brewed with. Try using bottled water, or distilled/RO water next time. If you can, a simple 2 stage, under the sink, water filter setup can filter out high 9's from the water (99.x%). Depending on the filter elements you use.

I would eliminate the possible sources of the chlorine for your next batch. One could very well be from the 'one step' that you simply didn't rinse well enough. It's one of the reasons I simply refuse to use ANY cleaner, or sanitizer, that has chlorine in it.


Chlorophenol
Tastes/Smells Like:
Plastic, Vinyl, Iodine
Possible Causes:
Using chlorinated tap water to brew or rinse equipment is the most common cause for plastic-like or medicinal flavors. Medicinal flavors can also be the result of using cleanser or sanitizer that is chlorine or iodine based. Some wild yeast will contribute to a similar medicinal taste.
How to Avoid:
Don’t use chlorinated water to brew or to rinse equipment that will come into contact with the beer. If chlorinated water must be used, use a water filter that removes chlorine or boil the water for 15 minutes and then cool to room temperature to force out any chlorine that may be present. Always use the recommended amount and concentrations of sanitizers. Most sanitizers will not cause any off flavors when used properly. When using bleach, use one-half ounce per gallon of water, let equipment
soak for 10 minutes and always rinse with sanitized (pre-boiled) water.

__________________
Hopping Tango Brewery

跟猴子比丟屎 ・ Gun HOE-tze bee DIO-se

On Tap: Caramel Ale, Mocha Porter II, MO SMaSH IPA
Waiting/Carbonating: 12.5% Wee Honey II, 8.9% Old Ale, English Brown Ale, Lickah ESB, Mocha Porter II
Fermenting
K1:
K2: Epic mead
K3: TripSix
On Deck: Caramel Ale
Aging:mead
Mead [bottled]:Oaked Wildflower Traditional, Mocha Madness, Blackberry Melomel, maple wine
Golddiggie is offline
 
Reply With Quote Quick reply to this message
Old 02-20-2012, 02:01 PM   #4
audger
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2011
Location: ., Connecticut
Posts: 1,497
Liked 40 Times on 40 Posts
Likes Given: 1

Default

if you are sure that you are using non-vinyl, beer-approved liquid lines, and the beer in the keg is actually plastic-y itself, my next thought would also be chlorophenol problems as mentioned above.

Quote:
I'm all freaked out about chlorine now, but I used a campden(for the first time ever in this batch).
next time, i would definately try not using campden and see if you get the same thing. or maybe use bottled water or invest in a charcoal filter... if that is all you changed, it would appear to have something to do with it, though i cant think of any reason that would explain it.
__________________
audger is offline
 
Reply With Quote Quick reply to this message
Old 02-20-2012, 04:18 PM   #5
kincade
HBT_SUPPORTER.png
Feedback Score: 0 reviews
Recipes 
 
Join Date: Aug 2008
Location: Utah
Posts: 374
Liked 6 Times on 6 Posts
Likes Given: 2

Default

If you think it might be water try using the ro water from harmons for a batch, costs only dollar a gallon or thereabouts. Id get a brush for the diptube as well and do a long pbw soak before kegging next time...

__________________

-kincade

kincade is offline
 
Reply With Quote Quick reply to this message
Old 02-20-2012, 09:32 PM   #6
tackucack
Feedback Score: 0 reviews
Recipes 
 
Join Date: Sep 2010
Location: Salt Lake City
Posts: 19
Default

Awesome tips guys, I'm definitely going to check it out. I honestly don't think it was water issues since my transfers tasted fine, and my batch after doesn't have the flavor either (bottled it last night) using the same method for brew day. That said I will still be getting water filtration going for my next batch, and this is the perfect opportunity to start more of the chemistry side of brewing.

I do wonder if it was the sanitizer/cleaning job I did. Although I did change out the o-rings, I think I was mainly focused on that part of it and not the actual cleaning of the keg thoroughly. I've bottled with one step in the past and had no issues, but I've been a Star san guy for a while now and should have done that too. I'll definitely inspect my dip tube and any other parts of the keg for the next round.

It's a bummer, I've never lost a batch before now. There goes my record! And yes, I'll save you a taste kincade. I'd love to get your input. And it's a good excuse for you to come by! Maybe a brew day in the next couple weeks?

__________________
tackucack is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kegging frustration. NHhomebrewer Bottling/Kegging 21 01-04-2012 12:43 PM
Drilling Frustration fenners Bottling/Kegging 14 08-29-2011 06:34 AM
Corny keg frustration (help) ardowling Bottling/Kegging 9 06-27-2011 03:06 PM
Keg frustration - leak - what now? Hannable1975 Bottling/Kegging 9 12-22-2010 03:56 PM