Happy HolidaySs Giveaway - Winners Re-Re-Re-Re-Drawn - 24 hours to Claim!

Get your HBT Growlers, Shirts and Membership before the Rush!


Home Brew Forums > Home Brewing Beer > Bottling/Kegging > Got used co2 and reg, something is wrong
Reply
 
LinkBack Thread Tools
Old 05-06-2012, 02:35 PM   #11
Esmitee
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2011
Location: Little Egg Harbor, At the Bay and Ocean, NJ
Posts: 517
Liked 21 Times on 19 Posts
Likes Given: 62

Default

Quote:
Originally Posted by 1KD1 View Post
I'll give it a shot. If I can get this fixed, I will be kegging today! I'm so excited!
Did you take that washer off and get it to stop leaking?
__________________
Thank You in Advance for your Time and Info....!
Esmitee is offline
 
Reply With Quote Quick reply to this message
Old 05-07-2012, 07:57 PM   #12
1KD1
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2012
Location: Kansas City, Missouri
Posts: 174
Default

Quote:
Originally Posted by Esmitee

Did you take that washer off and get it to stop leaking?
Yes, I removed the washer and o-ring, added some thread locker and all seems good now. I kegged a ranger clone and hope to be pulling a brew next weekend. I have high hopes for this beer but have gotten discouraged because most of the used kegs I acquired seem to have issues (bad poppets, bad relief valves, posts that are stripped, etc). I did buy some o-ring kits so I have been able to replace o-rings and mix/match parts until the keg finally held pressure. Hopefully I can get at least two kegs working (out of the 4 I purchased).
__________________
1KD1 is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools




Newest Threads

LATEST SPONSOR DEALS