Home Brew Forums

Home Brew Forums (http://www.homebrewtalk.com/forum.php)
-   Electric Brewing (http://www.homebrewtalk.com/f170/)
-   -   If I do it again ... forget the AMP and Volt Meters! (http://www.homebrewtalk.com/f170/if-i-do-again-forget-amp-volt-meters-247852/)

acefaser 05-26-2011 07:43 PM

If I do it again ... forget the AMP and Volt Meters!
 
These things are junk!
I am about half way through the build and was testing my meters out and noticed the Volt meter powers up, but doesn't read voltage. :mad:
The AMP meter never worked to begin with...
Even one of the adjustable DC converters didn't even work. New stuff is on the way but annoying and tired of waiting for crap parts from China.
Ok, rant over.

Hammy71 05-26-2011 07:59 PM

....or buy real tools. My Fluke and AMP meters work fine.

sv_1 05-26-2011 08:09 PM

Thanks for the heads up. I was about to order some tonight...

Bobby_M 05-26-2011 08:15 PM

Quote:

Originally Posted by Hammy71
....or buy real tools. My Fluke and AMP meters work fine.

Assume he's talking panel mount gauges.

wedge421 05-26-2011 08:25 PM

Ehh agreed they just dont seem worth the hardship

thelorax121 05-26-2011 08:27 PM

Same for me, both the meters haven't read since I powered up the panel, one only flashes meagerly, and the other is 100% dead. I am thinking about just covering the two cutouts with a name plate for my brewery rather than spending another $40 and waiting 3 weeks...

acefaser 05-26-2011 09:12 PM

ya its the panel mount meters. My tools work fine.
Funny thing is the Ebay guy I bought the volt meter from sent me a wiring diagram that is exactly opposite of what is on the back of the volt meter. He wanted me to wire it up using the diagram so I did. Turned on the power and POP! I just hope the replacement works...
The idiot Amp meter guys want me to send a picture of the amp meter not working so they can try to fix my problem. I have told them how I wired it but they insist on a picture. I sent them a picture of the meter mounted in my panel with no power to it. I think they are just stalling. I have a few more days to register a complaint with Ebay for my money back.

tmcmaster007 05-31-2011 03:43 PM

I'd skip these too if I had to do it all over. Single most challenging (read frustrating) part of the entire build. Ended up going through about 3 of each before I got two that worked. Does add a bit of bling to the panel, but not much needed data/info.

EarthBound 05-31-2011 04:35 PM

I'm glad I decided against them to begin with. I wouldn't have been able to fit them if I wanted to anyway.

kal 05-31-2011 05:49 PM

Quote:

Originally Posted by acefaser (Post 2956779)
These things are junk!
I am about half way through the build and was testing my meters out and noticed the Volt meter powers up, but doesn't read voltage. :mad:
The AMP meter never worked to begin with...
Even one of the adjustable DC converters didn't even work. New stuff is on the way but annoying and tired of waiting for crap parts from China.
Ok, rant over.

I'm assuming you're following my design...

How do you know they did not work when received? You may have hooked something up wrong and fried something without even knowing it (you won't always have a 'pop' or have smoke come out).

Not defending the sellers or their crappy documentation but the odds are very much against it. The odds of receiving 4/4 defective products ordered from 2-3 different places is almost zero.

The amp/volt meters are the things that people have the most difficulty in wiring up right. I get tons of emails about them. The poor documentation they come with certainly doesn't help. I would throw out the instructions and follow what's on the product itself.

If indeed you truly did receive 4/4 bad products, go out and buy a lottery ticket today! :)

Kal


All times are GMT. The time now is 01:20 AM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.