Ss Brewing Technologies Giveaway!

Home Brew Forums > Home Brewing Beer > Electric Brewing > HELP. Is my SSR bad?
Reply
 
LinkBack Thread Tools
Old 09-11-2011, 01:58 PM   #1
rsklhm10
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2011
Location: Saint Augustine, Fl
Posts: 181
Liked 2 Times on 2 Posts

Default HELP. Is my SSR bad?

So I finished up my control panel yesterday, very similar to Kal's build. Didn't really mess with it to much last night other than pluging it in and seeing if everything turned on (did not hook up elements).

Get up today and hook up elements and heres what happens. If there is no element hooked up to the outlet and I switch over the element switch, the notification light will come on. However, if I then hookup the element plug and flip the switch, no light???? Also, the relay I received from auberins has a little red light on it which is not lighting up. Also, if I take a voltmeter to the outlet, the line coming from the SSR is only showing like 30+- volts, whereas the other line straight from the power relay is showing 120.

Does this mean my SSR is bad? If so, then why will the indicator light come on when nothing is attached to the outlet, but then it won't when there is? Any immediate info is helpful

__________________
Primary: "Lake Night ESB," "Esquire IPA"
Secondary: Oatmeal Porter, Pumpkin Ale
Kegged: Centennial Blonde, "Turn-Two" Brew

My E-build:http://www.homebrewtalk.com/f170/another-e-build-267579/
rsklhm10 is offline
 
Reply With Quote Quick reply to this message
Old 09-11-2011, 02:05 PM   #2
passedpawn
Waste Allocation Load Lifter - Earth Class
HBT_MODERATOR.png
Feedback Score: 0 reviews
 
passedpawn's Avatar
Recipes 
 
Join Date: Apr 2009
Location: ☼ Clearwater, FL ☼
Posts: 18,903
Liked 3337 Times on 2065 Posts
Likes Given: 2841

Default

Connect a normal house lamp to the output on your SSR. If it turns on/off correcty, the SSR is working. This is the only good way to test the SSR. Ignore the voltmeter here.

Regarding the indicators, etc, sorry can't help there.

__________________
Hey goomba I love how you dance the rumba
But take some advice paisano learn-a how to mambo
If you're gonna be a square you ain't-a gonna go anywhere.
passedpawn is offline
 
Reply With Quote Quick reply to this message
Old 09-11-2011, 02:07 PM   #3
rsklhm10
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2011
Location: Saint Augustine, Fl
Posts: 181
Liked 2 Times on 2 Posts

Default

Also, there is definitely 120v coming in to the SSR from the power relay, but only like 20v coming out the other side. I have pin 7 from the pid to the + of the SSR and pin 8 to the - of the SSR.

__________________
Primary: "Lake Night ESB," "Esquire IPA"
Secondary: Oatmeal Porter, Pumpkin Ale
Kegged: Centennial Blonde, "Turn-Two" Brew

My E-build:http://www.homebrewtalk.com/f170/another-e-build-267579/
rsklhm10 is offline
 
Reply With Quote Quick reply to this message
Old 09-11-2011, 02:09 PM   #4
rsklhm10
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2011
Location: Saint Augustine, Fl
Posts: 181
Liked 2 Times on 2 Posts

Default

Quote:
Originally Posted by passedpawn View Post
Connect a normal house lamp to the output on your SSR. If it turns on/off correcty, the SSR is working. This is the only good way to test the SSR. Ignore the voltmeter here.

Regarding the indicators, etc, sorry can't help there.
What do you mean by connect a lamp to the output? Disconnect the side coming from the SSR to the element contactor and connect a lamp in its place? I feel like the SSR isn't even getting power from the pid...
__________________
Primary: "Lake Night ESB," "Esquire IPA"
Secondary: Oatmeal Porter, Pumpkin Ale
Kegged: Centennial Blonde, "Turn-Two" Brew

My E-build:http://www.homebrewtalk.com/f170/another-e-build-267579/
rsklhm10 is offline
 
Reply With Quote Quick reply to this message
Old 09-11-2011, 02:22 PM   #5
rsklhm10
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2011
Location: Saint Augustine, Fl
Posts: 181
Liked 2 Times on 2 Posts

Default

I'm retarded. The output was off on the pid....

__________________
Primary: "Lake Night ESB," "Esquire IPA"
Secondary: Oatmeal Porter, Pumpkin Ale
Kegged: Centennial Blonde, "Turn-Two" Brew

My E-build:http://www.homebrewtalk.com/f170/another-e-build-267579/
rsklhm10 is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools