*Ss Brewing Technologies Giveaway - Enter Now!*

Home Brew Forums > Home Brewing Beer > Electric Brewing > Heastick problem
Reply
 
LinkBack Thread Tools
Old 12-13-2010, 01:28 AM   #1
brewdogskip
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2009
Location: Western MD
Posts: 136
Liked 1 Times on 1 Posts

Default Heastick problem

So, I have been brewing with my stovetop and a heatstick for a while now and have had very positive results. While attempting to heat strike water for an ESB today, I plugged it in and noticed a louder noise than normal. It was the usual "hiss" sound but louder. My GFCI didn't trip and I unplugged it because it sounded weird.

Has anyone experienced this with a heatstick? Maybe it's time to build another...

__________________
brewdogskip is offline
 
Reply With Quote Quick reply to this message
Old 12-13-2010, 03:41 PM   #2
Cpt_Kirks
Feedback Score: 0 reviews
Recipes 
 
Join Date: Sep 2008
Location: Lakeland TN
Posts: 3,738
Liked 44 Times on 39 Posts

Default

If your GFCI didn't trip, you should be OK.

Make sure the "test" button on your GFCI is working.

I just fried a GFCI and had to replace it. It would trip randomly, was making a loud humming, and finally just locked up.

__________________
Cpt_Kirks is offline
 
Reply With Quote Quick reply to this message
Old 12-13-2010, 03:43 PM   #3
Gremlyn
Feedback Score: 0 reviews
Recipes 
 
Join Date: Mar 2009
Location: San Diego, CA
Posts: 2,524
Liked 24 Times on 16 Posts
Likes Given: 5

Default

+1 on the GFCI... if it works you're good.

__________________
Quote:
Originally Posted by Yooper View Post
I'm a fan of "getting it in the can"!
Gremlyn is offline
 
Reply With Quote Quick reply to this message
Old 12-13-2010, 04:15 PM   #4
brewdogskip
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2009
Location: Western MD
Posts: 136
Liked 1 Times on 1 Posts

Default

Thanks for the responses guys, I just did a lamp test to see if the circuit was actually tripping and it does work. Does anyone else notice a weird sound coming from their heatsticks?

__________________
brewdogskip is offline
 
Reply With Quote Quick reply to this message
Old 12-13-2010, 06:08 PM   #5
Cpt_Kirks
Feedback Score: 0 reviews
Recipes 
 
Join Date: Sep 2008
Location: Lakeland TN
Posts: 3,738
Liked 44 Times on 39 Posts

Default

Quote:
Originally Posted by brewdogskip View Post
Thanks for the responses guys, I just did a lamp test to see if the circuit was actually tripping and it does work. Does anyone else notice a weird sound coming from their heatsticks?
They do hiss from the rapid heating of the water.

Here is an idea: Could the louder sound be due to colder starting water? Is is pretty cold out in a lot of the country at the moment.
__________________
Cpt_Kirks is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools