Happy HolidaySs Giveaway - Last Sponsor Giveaway of the Year!

Come Enter the BrewDeals/FastFerment Giveaway!


Home Brew Forums > Home Brewing Beer > Electric Brewing > First brew on my electric system.
Reply
 
LinkBack Thread Tools
Old 01-09-2012, 05:28 PM   #1
mcgeebc
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2007
Location: Cleveland, OH
Posts: 90
Liked 2 Times on 2 Posts

Default First brew on my electric system.

First of all, big thank you to all of the people that post to this board. I've been dreaming up an electric brewery for 2+ years now. Researching, planning and collecting parts (I bought a spa panel when I read they went on sale 1.5 years ago. It was just wired on Saturday). I originally wanted to do a BCS or brewtroller build, then a more complicated PID build like theelectricbrewery. As time went on, I kept deciding to scale back. I ended up with a very simple toolbox control panel Brutus 20 system. My plan is to build on as time goes on.

I finally had my first brew on the new system yesterday and it went great!

My wife was due to give birth to our first child on the same day, so I'm glad I got it in when I did.

Link to my control panel description

Bad picture of everything mostly put together:


Passedpawn - you were right on about the switch. There were times I really wished I had one to just shut it off without switching to manual mode on the PID and taking the % down to 0. I'm going to install the switch you suggested before my next brew.

The heatsink seemed to be okay in the box. I opened my box a few times during the boil. The heatsink itself was hot to to touch, but the temp in the box never got above 100 degrees.

Boiling looked pretty strange with an electric system. It seems like I needed to have a very vigorous boil to keep it constant. If I turned it down to a nice rolling boil, it would bubble up when the element switched on and go flat when the element was switched off.

What percentage are others setting their PID on with a 5500 watt element and ~ 6.5 gallons pre-boil? I tried a range between 45 - 80%. I don't feel like I ever hit the sweet spot. Does anyone have a good video of what their boil looks like?

I also had some trouble with condensation on my hood. I got a nice deal on a 36" stainless steel 550 CFM Broan hood. The problem is that I had to reduce it from 3 1/4 X 14 down to a 4" round dryer vent outlet in a glass block window. It takes most of the steam out, but I get a lot of water build up on the hood itself. It drips back into the pot and on my stand throughout the boil. Good thing I decided to build the stand with treated wood.

I'll probably raise the hood to see if that helps with condensation. If it continues to be a problem, should I be concerned? As long as the hood is clean, do I need to worry about water dripping back into the kettle?

All and all, it was the easiest and most enjoyable all grain brew that I've done. I love being able to brew inside with all of my stuff at my fingertips. No more running inside and down the stairs to grab something I forgot.

Thanks again everyone!

__________________
mcgeebc is offline
 
Reply With Quote Quick reply to this message
Old 01-09-2012, 06:20 PM   #2
Lucky_Chicken
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jul 2011
Location: Bloomfield, IA
Posts: 791
Liked 34 Times on 25 Posts
Likes Given: 4

Default

dripping back only provides problems with the chemicals you are trying to boil off. you are still boiling it so until you stop boiling it will sanatize itself. I would try to keep it from dripping in the pot if you can.

Lucky_Chicken is offline
 
Reply With Quote Quick reply to this message
Old 01-09-2012, 06:33 PM   #3
P-J
HBT_LIFETIMESUPPORTER.png
Feedback Score: 0 reviews
Recipes 
 
Join Date: Mar 2010
Location: Charlotte, NC
Posts: 3,283
Liked 259 Times on 207 Posts
Likes Given: 454

Default

Quote:
Boiling looked pretty strange with an electric system. It seems like I needed to have a very vigorous boil to keep it constant. If I turned it down to a nice rolling boil, it would bubble up when the element switched on and go flat when the element was switched off.
Which PID are you using? Auber Instruments SYL-2352? If so - you need to set up the cycle time for 2 seconds.

Quote:
4.6 Cycle time “t”
It is the time period (in seconds) that the controller uses to calculate its
output. e.g. When t=2, if the controller decides output should be 10%, the
heater will be on 0.2 second and off 1.8 seconds for every 2 seconds. Smaller
t values result in more precision control. For SSR output, t is set at the
minimum (2 seconds). For relay or contactor output, it should be set longer to
prevent contacts from wearing out too soon. Normally it is set to 20~ 4 0
seconds.
__________________
P-J is offline
 
Reply With Quote Quick reply to this message
Old 01-10-2012, 02:15 AM   #4
mcgeebc
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2007
Location: Cleveland, OH
Posts: 90
Liked 2 Times on 2 Posts

Default

Quote:
Originally Posted by P-J
Which PID are you using? Auber Instruments SYL-2352? If so - you need to set up the cycle time for 2 seconds.
I had it set to 10. I just changed to 2. Hope that doesn't cause my SSR to run too hot now.
__________________
mcgeebc is offline
 
Reply With Quote Quick reply to this message
Old 01-10-2012, 02:32 AM   #5
bigljd
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2010
Location: Sacramento, CA
Posts: 471
Liked 22 Times on 18 Posts
Likes Given: 6

Default

I had trouble with a pulsing boil to until I changed P=1 and T=2. I made a note of what the autotune settings were and have P=301 and T=6 to maintain HLT temps (those values may be different on your system). When I switch to manual mode for the boil in the kettle I'll change them to P=1 and T=2. It works very good in both modes now.

Here's the thread I learned about the pulsing boil settings:
http://www.homebrewtalk.com/f170/pul...3/#post3002292

PS: I run a 5 gal batch at 55% for the boil (5500 watt element). I could go a little less but I like a hard boil.

bigljd is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electric Brew System Questions Lou1998 Electric Brewing 8 10-06-2011 04:34 PM
My electric system ver 6 missing link Electric Brewing 3 09-09-2011 05:33 AM
Finally...New Electric Brew System is complete. NTabb Electric Brewing 6 02-28-2011 02:07 PM
Portable electric AG system LordUlrich Electric Brewing 5 12-29-2010 04:54 AM



Newest Threads

LATEST SPONSOR DEALS