Get your HBT Growlers, Shirts and Membership before the Rush!


Home Brew Forums > Home Brewing Beer > Electric Brewing > Ew, look at my RIMS element
Reply
 
LinkBack Thread Tools
Old 06-12-2011, 01:51 AM   #21
missing link
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jul 2007
Location: Highland, MI
Posts: 667
Liked 2 Times on 2 Posts

Default

I run PBW through mine for almost an hour just to get the PBW up to 170 which they say is the ideal cleaning temperature for that product.

Linc

__________________

Tap#1 = Beer
Tap#2 = Beer

THey change to often to keep up with the Sig.

missing link is offline
 
Reply With Quote Quick reply to this message
Old 06-12-2011, 07:16 PM   #22
pola0502ds
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2011
Posts: 832
Liked 2 Times on 2 Posts

Default

Quote:
Originally Posted by missing link View Post
I run PBW through mine for almost an hour just to get the PBW up to 170 which they say is the ideal cleaning temperature for that product.

Linc
Did not know that, thanks.
__________________
pola0502ds is offline
 
Reply With Quote Quick reply to this message
Old 06-13-2011, 07:45 PM   #23
Quaffer
Feedback Score: 0 reviews
Recipes 
 
Join Date: Dec 2008
Location: Snohomish, WA
Posts: 488
Liked 26 Times on 15 Posts
Likes Given: 1

Default

Quote:
Originally Posted by ikonis View Post
I pulled it out today after I don't know how many batches. Surprisingly, it was still working!

What's weird is I always run pbw and saniclean through it for about an hour after each brew.

It looks to be rectorseal and caramelized sugars all over the element.
I have been following Trigger's thread about gunk on the element, so I remove it after each brew. My tube is made from 1.5" ss fittings (like yours I believe), and it is easy to take apart. The trick is to make the tube easy to remove from the structure.

So far my RIMS heater has had what looks like sloppy oat meal on it after circulating OxiClean and heating for 30 minutes. The gunk has come off easily with a dish brush and nothing seems to have stuck to the element though.
__________________

Alcohol, the source of - and solution to - all of life’s problems. H.J.S.
My keezer, My E-brewery build thread, How I soldered 1" nut for heater

Quaffer is offline
 
Reply With Quote Quick reply to this message
Old 06-13-2011, 08:51 PM   #24
ikonis
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2009
Location: Tyler, TX
Posts: 191
Liked 2 Times on 1 Posts
Likes Given: 2

Default

Quote:
Originally Posted by Quaffer View Post
I have been following Trigger's thread about gunk on the element, so I remove it after each brew. My tube is made from 1.5" ss fittings (like yours I believe), and it is easy to take apart. The trick is to make the tube easy to remove from the structure.

So far my RIMS heater has had what looks like sloppy oat meal on it after circulating OxiClean and heating for 30 minutes. The gunk has come off easily with a dish brush and nothing seems to have stuck to the element though.
I've since added some triclamp fittings for easy removal
__________________
Tyler's Brewing Supply
East Texas's ONLY Homebrew Supply Shop
ikonis is offline
 
Reply With Quote Quick reply to this message
Old 06-13-2011, 10:37 PM   #25
Coldies
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2010
Location: Carlsbad, CA
Posts: 570
Liked 5 Times on 5 Posts
Likes Given: 1

Default

Quote:
Originally Posted by ikonis View Post
I've since added some triclamp fittings for easy removal
Did you add the triclamp fittings to your 1 1/2" pipe? I was thinking about doing this as well. Just where the element screws into the "T" fitting.
__________________
Coldies is offline
 
Reply With Quote Quick reply to this message
Old 06-13-2011, 10:47 PM   #26
ikonis
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2009
Location: Tyler, TX
Posts: 191
Liked 2 Times on 1 Posts
Likes Given: 2

Default

Quote:
Originally Posted by Coldies View Post
Did you add the triclamp fittings to your 1 1/2" pipe? I was thinking about doing this as well. Just where the element screws into the "T" fitting.
Yup. Added a 1.5" mnpt to 1.5" tc fitting on the tube. And a 1" fnpt to 1.5" tc on the element. Then attached the element like kal with a single gang electrical box
__________________
Tyler's Brewing Supply
East Texas's ONLY Homebrew Supply Shop
ikonis is offline
 
Reply With Quote Quick reply to this message
Old 06-13-2011, 11:49 PM   #27
Coldies
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2010
Location: Carlsbad, CA
Posts: 570
Liked 5 Times on 5 Posts
Likes Given: 1

Default

Quote:
Originally Posted by ikonis View Post
Yup. Added a 1.5" mnpt to 1.5" tc fitting on the tube. And a 1" fnpt to 1.5" tc on the element. Then attached the element like kal with a single gang electrical box
Would you mind throwing up a picture when you get a chance. Thanks man. I was looking at the triclamp fitting for elements from brewers hardware and that thing looks slick. But with the 1.5" mnpt to 1.5" triclamp plus this I would be out another $100.00
__________________
Coldies is offline
 
Reply With Quote Quick reply to this message
Old 06-27-2011, 01:03 PM   #28
pola0502ds
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2011
Posts: 832
Liked 2 Times on 2 Posts

Default

I am having a little rust form on the base of my element. None what-so-ever on the element prongs. Can I leave this little bit of rust on the base of the element and not have any problems or should I find a way to remove it. That brings up my next question, how do you remove the rust?

__________________
pola0502ds is offline
 
Reply With Quote Quick reply to this message
Old 06-28-2011, 03:41 PM   #29
Coldies
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2010
Location: Carlsbad, CA
Posts: 570
Liked 5 Times on 5 Posts
Likes Given: 1

Default

Quote:
Originally Posted by pola0502ds View Post
how do you remove the rust?
Elbow grease. Or throw a small layer of food grade silicone on the base to seal it up.
__________________
Coldies is offline
 
Reply With Quote Quick reply to this message
Old 06-28-2011, 05:50 PM   #30
SpanishCastleAle
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2009
Location: Central Florida
Posts: 4,384
Liked 29 Times on 29 Posts

Default

Quote:
Originally Posted by kshuler View Post
Also, what about using caustic on the elements- I have a pound of pure sodium hydroxide that I have been considering running through the system.
FWIW, I have a couple of heated caustic tanks at work and we use the Incoloy elements in them. They last for many years as long as you don't let the salts build-up too much and cover them up (don't ask how I know this), but for you this shouldn't be a problem (the salts build-up from frequent cooling/heating over the course of many months).
__________________
Early brewers were primarily women, mostly because it was deemed a woman's job. Mesopotamian men, of some 3,800 years ago, were obviously complete assclowns and had yet to realize the pleasure of brewing beer.- Beer Advocate
SpanishCastleAle is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools




Newest Threads

LATEST SPONSOR DEALS