Ss Brewing Technologies Giveaway!

Home Brew Forums > Home Brewing Beer > Electric Brewing > Element Issue
Reply
 
LinkBack Thread Tools
Old 07-15-2011, 07:01 PM   #1
bullywee
Feedback Score: 0 reviews
Recipes 
 
Join Date: Dec 2008
Location: Greensboro NC
Posts: 185
Likes Given: 2

Default Element Issue

Am I missing something?

BCS is off line so I tried to brew in MANUAL, my pumps work but I have no heat @ HLT & BK?

I have power @ the element connections of both HLT & BK
Grounds are all good
elements have continuity terminal to terminal.


could both elements be bad????

thanks.

__________________
bullywee is offline
 
Reply With Quote Quick reply to this message
Old 07-15-2011, 07:40 PM   #2
bullywee
Feedback Score: 0 reviews
Recipes 
 
Join Date: Dec 2008
Location: Greensboro NC
Posts: 185
Likes Given: 2

Default

Duh, a whole half of my garage 120v outlets were out/inop so no 5v (5v to BCS/SSR in MAN)

BrewDay back on.


Quote:
Originally Posted by bullywee View Post
Am I missing something?

BCS is off line so I tried to brew in MANUAL, my pumps work but I have no heat @ HLT & BK?

I have power @ the element connections of both HLT & BK
Grounds are all good
elements have continuity terminal to terminal.


could both elements be bad????

thanks.
__________________
bullywee is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
tri-clover removable element - brewershardware element adapter canyonbrewer Electric Brewing 44 04-22-2013 02:24 AM
What does your element look like? dboblitt Electric Brewing 4 01-10-2012 03:08 PM
how big is the installed element? kappclark Electric Brewing 3 03-20-2011 09:21 PM
Element Wiring McCuckerson Electric Brewing 13 03-10-2011 02:39 AM
Dry element question thantos Electric Brewing 3 01-25-2011 03:53 PM