The Great Bottle Opener Giveaway

Home Brew Forums > Home Brewing Beer > Electric Brewing > Dead ssr?

Reply
 
LinkBack Thread Tools
Old 08-12-2011, 08:58 PM   #11
mredge73
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
mredge73's Avatar
Recipes 
 
Join Date: May 2011
Location: La Porte, TX
Posts: 618
Liked 30 Times on 30 Posts

Default

Quote:
Originally Posted by gitapaynts View Post
I'm still wondering if anyone has measured resistance across the switch terminals of an ssr when there is no inout trigger signal and if they see 0 resistance like I do.
You have a direct short, toss it and get a new one.
You should be seeing resistance in the MegaOhms or near Infinite.
__________________
mredge73 is offline
 
Reply With Quote Quick reply to this message
Old 08-12-2011, 11:35 PM   #12
jkarp
Beer Herder
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
jkarp's Avatar
Recipes 
 
Join Date: Jun 2008
Location: Elizabeth, CO
Posts: 2,105
Liked 33 Times on 29 Posts
Likes Given: 4

Default

Quote:
Originally Posted by gitapaynts View Post
Just got home and per PJ unhooked the ssr and checked the element output. I get 1 volt across hots, 120 from 1 leg to neutral and 55 from the leg that was going through the ssr to neutral. The first two make sense to me, but I don't understand why I would get 55 from between the neutral and the disconnect other hot leg.
You MUST test an SSR with a proper load. Your DVM is useless.
__________________

Many Bothans died to bring you this information.

jkarp is offline
 
Reply With Quote Quick reply to this message
Old 08-12-2011, 11:57 PM   #13
jkarp
Beer Herder
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
jkarp's Avatar
Recipes 
 
Join Date: Jun 2008
Location: Elizabeth, CO
Posts: 2,105
Liked 33 Times on 29 Posts
Likes Given: 4

Default

Quote:
Originally Posted by mredge73 View Post
You have a direct short, toss it and get a new one.
You should be seeing resistance in the MegaOhms or near Infinite.
I misread that part from gitapaynts. This is correct. Resistance across the output terminals should be infinite with no input. This one test doesn't verify correct SSR operation however. A simple load like a lamp is the best test.
__________________

Many Bothans died to bring you this information.

jkarp is offline
 
Reply With Quote Quick reply to this message
Old 08-14-2011, 08:26 PM   #14
gitapaynts
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2007
Location: Atlanta, Georgia
Posts: 17
Liked 4 Times on 3 Posts

Default

Just did the light bulb test. I didn't bother digging out a 9 volt battery from the closet, just wired in a lamp through the SSR with all power off. As expected, the light worked, so I'm concluding the SSR is indeed fried closed. Ordering a new one now.

My built in digital ammeter also doesn't work correctly, reading 0.1A without adding load other than the LED lights and PID, and when adding either the element or pump, the meter simply oscillates in the tenths of an Amp. I'm going to go ahead and order a new one as well....

Thanks for the hints!

__________________
gitapaynts is offline
 
Reply With Quote Quick reply to this message
Old 08-15-2011, 01:43 AM   #15
sdugre
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2011
Location: Holyoke, MA
Posts: 106
Default

Quote:
My built in digital ammeter also doesn't work correctly
You may have a blown fuse. I'd check before buying a new one.
__________________
sdugre is offline
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options
Thread Tools