Spike Brewing 12.5 Conical Fermenter Giveaway!

Home Brew Forums > Home Brewing Beer > Electric Brewing > 50amp GFI keeps tripping.

Reply
 
LinkBack Thread Tools
Old 04-30-2013, 02:00 AM   #1
funkdaddydowd
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2011
Location: Rochester, NY
Posts: 1
Default 50amp GFI keeps tripping.

I just bought a BIAB Electric set up from High Gravity Brewing
http://www.highgravitybrew.com/productcart/pc/BIAB-Electric-Brewing-System-306p3987.htm

I have installed a new 30amp breaker at my main panel, which feeds a spa 50amp GFCI disconnect. Off of the GFCI is a 4 pin receptacle that feeds the controller with a PID and a pump controller.

To test out my set up I went to turn on the PID without the heating element plugged in as soon as I do the GFCI trips.

I have tried to trouble shoot this and I can't figure it out. I wired the controller straight in to the 30amp breaker (bypassing the GFCI) and it works just fine. I had a friend help me with this who is an electrician and he is stumped as well.

Any help would be appreciated.

__________________
funkdaddydowd is offline
 
Reply With Quote Quick reply to this message
Old 04-30-2013, 02:17 AM   #2
raouliii
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
raouliii's Avatar
Recipes 
 
Join Date: Aug 2011
Location: Ponchatoula, LA
Posts: 766
Liked 62 Times on 55 Posts
Likes Given: 89

Default

Not sure exactly how you're wired up but here's a general question. Does the GFI breaker monitor ALL current carrying conductors? 240v circuit: both hots. 120v circuit: hot AND neutral

__________________
On Tap:
NippleRub Ultra
Ranger(ish) IPA clone
Horizocade Amber
Rochefort 7

In the Chamber:
Big Breasted Blonde

Next Up:
????
raouliii is offline
 
Reply With Quote Quick reply to this message
Old 04-30-2013, 02:20 AM   #3
tyzippers
Feedback Score: 4 reviews
Recipes 
 
Join Date: Jan 2012
Location: Meadville, PA
Posts: 2,315
Liked 404 Times on 300 Posts
Likes Given: 147

Default

Is the white wire from the GFCI breaker attached to the neutral bus? I know it's an obvious thing to check, but I feel it needs to be asked. Other than that, there must be a place where there is either a short to ground. With the main (30A) panel breaker OFF, use a multimeter to determine if there's a short to ground via a possible error in wiring. That's all I can think of at the moment. Also, with out actually being there to see the install and inspect the wiring, it's kind of hard to make other suggestions. Others may have better luck than I.

__________________
tyzippers is offline
 
Reply With Quote Quick reply to this message
Old 04-30-2013, 02:38 AM   #4
jeffmeh
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
jeffmeh's Avatar
Recipes 
 
Join Date: Feb 2009
Posts: 1,816
Liked 131 Times on 112 Posts
Likes Given: 17

Default

Do you have 3 wires in and 4 wires out in the spa panel? If so, see P-J's photo-diagram here. http://www.homebrewtalk.com/f170/spa-panel-wiring-dummies-266751/

__________________
jeffmeh is online now
 
Reply With Quote Quick reply to this message
Old 04-30-2013, 02:38 AM   #5
Spiny-Norman
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2013
Posts: 11
Liked 4 Times on 2 Posts
Likes Given: 2

Default

Is your neutral and ground hooked together anywhere except for your primary breaker panel?

Redundant grounds are bad and cause gfci's not to work so well.

__________________
Spiny-Norman is offline
 
Reply With Quote Quick reply to this message
Old 04-30-2013, 02:48 AM   #6
thomashp
HBT_LIFETIMESUPPORTER.png
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2008
Location: Richmond, VA, Richmond, VA
Posts: 55
Default

Have you contacted the manufacturer of that control box? It might be a known issue.

Some switching power supplies are know to trip GFCI breakers as well. I wonder what is in that control box.

__________________
thomashp is offline
 
Reply With Quote Quick reply to this message
Old 04-30-2013, 03:07 AM   #7
Spiny-Norman
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2013
Posts: 11
Liked 4 Times on 2 Posts
Likes Given: 2

Default

Gfci is not normally used for electronic controls because of "Leakage"
I do not know what you are running off of this. but..... That may be the issue.

__________________
Spiny-Norman is offline
 
Reply With Quote Quick reply to this message
Old 04-30-2013, 12:11 PM   #8
jeffmeh
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
jeffmeh's Avatar
Recipes 
 
Join Date: Feb 2009
Posts: 1,816
Liked 131 Times on 112 Posts
Likes Given: 17

Default

If a properly-functioning spa panel is wired correctly, and you brought H-H-N-G out of it, it should work. If you only have H-H-G, that controller will not work with a GFCI. From the product page on the controller:

"Requires 220V 30A service. Includes a 6 ft power cord with either a 3-wire plug (NEMA 10-30P) or a 4-wire plug (NEMA 14-30P). GFCI type breaker cannot be used with the 3-wire installation. GFCI must use 4-wire installation with separate neutral and ground."

__________________
jeffmeh is online now
 
Reply With Quote Quick reply to this message
Old 07-22-2013, 06:41 PM   #9
owentp
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2012
Location: Mattawan, MI
Posts: 311
Liked 2 Times on 2 Posts

Default

I have the same thing and similar problem except for my PID/Thermostat comes on but whenever plug in the pump and flip the pump switch, it trips the spa panel GFCI.

__________________
owentp is offline
 
Reply With Quote Quick reply to this message
Old 07-22-2013, 06:54 PM   #10
raouliii
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
raouliii's Avatar
Recipes 
 
Join Date: Aug 2011
Location: Ponchatoula, LA
Posts: 766
Liked 62 Times on 55 Posts
Likes Given: 89

Default

Quote:
Originally Posted by owentp View Post
I have the same thing and similar problem except for my PID/Thermostat comes on but whenever plug in the pump and flip the pump switch, it trips the spa panel GFCI.
I would suggest you start by answering the questions posed earlier in this thread.
__________________
On Tap:
NippleRub Ultra
Ranger(ish) IPA clone
Horizocade Amber
Rochefort 7

In the Chamber:
Big Breasted Blonde

Next Up:
????
raouliii is offline
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
50amp GFCI Spa panel safe at well below 50amps? Chello Electric Brewing 27 04-04-2013 10:53 AM
General Wiring Questions On A 240v 50amp Line jdlev Electric Brewing 43 07-20-2012 03:04 PM
For Sale - 50amp Plasma Cutter / Torch cripplecreek For Sale 4 07-03-2012 11:17 AM
Two 2000w on 120v 50amp Circuit? seatbelt123 Electric Brewing 13 01-10-2012 08:53 PM
Road Tripping brewmaster12 General Beer Discussion 1 12-17-2011 06:37 PM