Electric Brewing Supply 30A BCS Giveaway!


Home Brew Forums > Home Brewing Beer > Fermentation & Yeast > WLP530 Abbey Ale - Sulfur Smell
Reply
 
LinkBack Thread Tools
Old 06-05-2012, 02:21 AM   #1
dgoldb1
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2007
Location: Baltimore, MD
Posts: 380
Liked 1 Times on 1 Posts
Likes Given: 4

Default WLP530 Abbey Ale - Sulfur Smell

I'm about 48 hrs into the ferment of my Belgian Blonde with WLP530. My whole basement smell of a very pungent sulfur smell. I've brewed many beers and have never had this from a yeast. It's almost something I would expect from a lager yeast. Has anyone had this before?

__________________
dgoldb1 is offline
 
Reply With Quote Quick reply to this message
Old 06-05-2012, 04:39 AM   #2
Reno_eNVy
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
Reno_eNVy's Avatar
Recipes 
 
Join Date: Oct 2008
Location: Reno, Nevada
Posts: 6,244
Liked 197 Times on 166 Posts
Likes Given: 68

Default

I don't think this one is known to be sulfury.

1) What was the wort OG and how much yeast did you pitch?

2) What temp is it hanging out at?

3) Did you aerate?

__________________
Primary: air and sadness =(

Kegged: Cascadian Dark Ale

Bottled: English Barleywine (brewed 9/26/09 -- bottled 5/5/10)


LET'S GO LA!
LA CAMPEONES!
PLAY FOR GLORY, THE GLORY LA!
Reno_eNVy is offline
 
Reply With Quote Quick reply to this message
Old 06-05-2012, 06:38 PM   #3
dgoldb1
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2007
Location: Baltimore, MD
Posts: 380
Liked 1 Times on 1 Posts
Likes Given: 4

Default

Quote:
Originally Posted by Reno_eNVy View Post
I don't think this one is known to be sulfury.

1) What was the wort OG and how much yeast did you pitch?

2) What temp is it hanging out at?

3) Did you aerate?
OG was 1.060. Pichted a 1.3L starter.

Temp is controlled at 64*

Yes, with O2.
__________________
dgoldb1 is offline
 
Reply With Quote Quick reply to this message
Old 06-05-2012, 07:11 PM   #4
Reno_eNVy
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
Reno_eNVy's Avatar
Recipes 
 
Join Date: Oct 2008
Location: Reno, Nevada
Posts: 6,244
Liked 197 Times on 166 Posts
Likes Given: 68

Default

Hmm....

Do you happen to know the production date of the yeast?

__________________
Primary: air and sadness =(

Kegged: Cascadian Dark Ale

Bottled: English Barleywine (brewed 9/26/09 -- bottled 5/5/10)


LET'S GO LA!
LA CAMPEONES!
PLAY FOR GLORY, THE GLORY LA!
Reno_eNVy is offline
 
Reply With Quote Quick reply to this message
Old 06-05-2012, 07:25 PM   #5
dgoldb1
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2007
Location: Baltimore, MD
Posts: 380
Liked 1 Times on 1 Posts
Likes Given: 4

Default

5/10/2012

__________________
dgoldb1 is offline
 
Reply With Quote Quick reply to this message
Old 06-05-2012, 09:40 PM   #6
Reno_eNVy
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
Reno_eNVy's Avatar
Recipes 
 
Join Date: Oct 2008
Location: Reno, Nevada
Posts: 6,244
Liked 197 Times on 166 Posts
Likes Given: 68

Default

Hmmm... well as far as melon-scratchers go, this one is a honeydew. *BA-DA CHA*

But seriously, you've got me stumped. Anybody else want to chime in?

__________________
Primary: air and sadness =(

Kegged: Cascadian Dark Ale

Bottled: English Barleywine (brewed 9/26/09 -- bottled 5/5/10)


LET'S GO LA!
LA CAMPEONES!
PLAY FOR GLORY, THE GLORY LA!
Reno_eNVy is offline
 
Reply With Quote Quick reply to this message
Old 06-05-2012, 10:45 PM   #7
ChillWill
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2011
Location: Sheffield, South Yorkshire
Posts: 856
Liked 14 Times on 14 Posts
Likes Given: 1

Default

It's just sulphury, it happens. Sometimes it's from yeast stress, some strains just kick off plenty... even some hop varieties have high levels.

It's volatile though so co2 leaving the beer will get rid of it. I used some Wlp540 (rochefort), it was old but I made a starter, did a cell count and it was reasonable so pitched it.... I nearly puked when I went near it as it was throwing off so much sulphur. Turned out fine though. Score.

__________________
ChillWill is offline
 
Reply With Quote Quick reply to this message
Old 06-06-2012, 02:21 AM   #8
dankbeer
Feedback Score: 0 reviews
Recipes 
 
Join Date: Mar 2010
Location: Asheville, NC
Posts: 37
Likes Given: 3

Default

I"ve used WLP530 many times to ferment styles ranging from belgian quad to abbey... even cider. Each time I used that yeast I have noticed a sulphur smell and each batch turned out fine. No sulphur in the aroma or flavor of the finished product.

__________________
dankbeer is offline
 
Reply With Quote Quick reply to this message
Old 06-20-2012, 02:59 AM   #9
dgoldb1
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jan 2007
Location: Baltimore, MD
Posts: 380
Liked 1 Times on 1 Posts
Likes Given: 4

Default

Ok, I wanted to post an update. The smell now is horrific, like something died in my fermentation chamber. I've brewed 15+ batches and I've never had something smell like this before. I took a sample and it's down to 1.012...perfect. It tasted pretty good too. What the hell is going on?

__________________
dgoldb1 is offline
 
Reply With Quote Quick reply to this message
Old 06-20-2012, 06:48 AM   #10
MrPostman
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2011
Location: Tulsa, OK
Posts: 54
Liked 1 Times on 1 Posts

Default

Sounds most likely that you have an infection of a weird Brettanomyces strain coupled with a big boost of carpylic acid which smells rancid, goaty, terribly much like death.

:edit:
Also, just call it a lambic now and you're good. proceed with fermentation, open up the top of it to let it out gas as much as possible, and keep it on the warmer side to keep the yeast healthy. pay attention to the SG and what the yeast look like and as soon as it's done cool it gradually to 40 degrees and keep it there or lower (to about 37) so as not to shock the yeast but to encourage them to clean up a bit while floccing.

__________________

Reason: forgot the fixer!
MrPostman is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools