Kegconnection Complete Starter Kit and More Giveaway!


Home Brew Forums > Home Brewing Beer > Fermentation & Yeast > Possible infected starter?

Reply
 
LinkBack Thread Tools
Old 05-27-2010, 03:10 PM   #1
Atticmonkey
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2005
Location: La Salle, IL
Posts: 114
Default Possible infected starter?

Hey guys,
I am looking to brew a bavarian hefe soon and started bring my yeast starter up from a slant of wlp 300. This is my first time using this yeast and first time cultureing up a hefe yeast. The starter was cultured from 10ml to 100ml to 1000ml. So this morning I took a sample from the starter to taste to make sure everything was good and the sample has a slight tartness to it. Not smack you in the face tart but also Im not getting any banana or clove taste. The starter wort was all extra light dme so I dont think there is any wheat in it. So has anybody ever worked with this yeast enough to know if that is a normal flavor? And is it possible that its from the non wheat base wort? Thanks in advance.

__________________
Life is like a plate of chitlins, everythings fine till you realize what your eating.
Atticmonkey is offline
 
Reply With Quote Quick reply to this message
Old 08-04-2010, 07:29 PM   #2
spriolo
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jun 2010
Location: West Michigan
Posts: 71
Default

What do you mean by tart? Green Apple?

What was your starter temp? High 70's?

__________________
spriolo is offline
 
Reply With Quote Quick reply to this message
Old 08-04-2010, 07:33 PM   #3
Gremlyn
Feedback Score: 0 reviews
Recipes 
 
Join Date: Mar 2009
Location: San Diego, CA
Posts: 2,524
Liked 24 Times on 16 Posts
Likes Given: 5

Default

Starter wort never tastes good in my experience...

__________________
Quote:
Originally Posted by Yooper View Post
I'm a fan of "getting it in the can"!
Gremlyn is offline
 
Reply With Quote Quick reply to this message
Old 08-05-2010, 05:12 AM   #4
Atticmonkey
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2005
Location: La Salle, IL
Posts: 114
Default

It wasnt acidic tart but just seemed to have a slight sourness to it. I think my starter temp was somewhere around 70 degrees. I ended up stepping it up to a full liter starter and it worked fine. I think it was just the taste of the hefe yeast that seemed to give it the tartness. The beer fermented out fine and tasted great so I guess I just was a little paranoid.

__________________
Life is like a plate of chitlins, everythings fine till you realize what your eating.
Atticmonkey is offline
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my starter infected? mjs483 Fermentation & Yeast 6 03-21-2010 11:11 PM
Tell me my starter isn't infected jldc Fermentation & Yeast 6 12-04-2009 02:46 AM
Is my starter infected?? mroberts1204 Beginners Beer Brewing Forum 8 07-22-2009 10:04 PM
Is my Starter Infected? Should I use it? efreem01 Beginners Beer Brewing Forum 6 07-27-2008 08:46 PM
Big Starter - Is it infected? Schlenkerla General Techniques 11 03-14-2008 02:03 PM