Home Brew Forums

Home Brew Forums (http://www.homebrewtalk.com/forum.php)
-   Fermentation & Yeast (http://www.homebrewtalk.com/f163/)
-   -   My starter never started? (http://www.homebrewtalk.com/f163/my-starter-never-started-338726/)

TreeHugger 06-30-2012 12:17 PM

My starter never started?
 
I made a starter on Thursday night(it is now Saturday morning) with 2 oz dme to 400 ml water. boiled for 10 minutes and pitched a dry pack of nottingham in the and secured an airlock. I use a 1000 ml beaker for starters.

I have not seen any visible signs of fermentation and am concerned. There is however a cake on the bottom. Am I good to pitch? Are the yeast cells dead or just not very active yet?

Thanks!

clemson51 06-30-2012 12:58 PM

Sounds to me like it fermented if cake on the bottom.

SavoryChef 06-30-2012 03:18 PM

Did you chill the wort or pitch the yeast when it was hot? You didn't specify. Some of my starters are not very active. Take a gravity reading.

TreeHugger 06-30-2012 04:39 PM

cooled to 70 degrees.

ghall 06-30-2012 04:44 PM

Sounds fine. Give it a good stir and pitch. Do you have a stir plate? Just made one myself and it seemed to really help my starters.

ghall 06-30-2012 04:46 PM

Sorry to double post but the other thing to that a brewer friend told me was to not use an airlock but instead a loose piece of aluminum foil or sanitized sponge. He said for starters you want to give the yeast oxygen and the airlocks really prevent them for working as good as they could.

TreeHugger 07-02-2012 02:20 PM

Yeast worked fine. I guess it was a quick one then settled out on the bottom as a cake.


All times are GMT. The time now is 06:12 PM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.