Home Brew Forums > Home Brewing Beer > Fermentation & Yeast > Bad lot of Safale US-05
Reply
 
LinkBack Thread Tools
Old 10-26-2011, 01:20 AM   #1
scottland
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2010
Location: Chandler, AZ
Posts: 2,117
Liked 141 Times on 105 Posts
Likes Given: 12

Default Bad lot of Safale US-05

My last few fermentations with US05 have been off. They've had long lag times, and slow ferments. I know this yeast very well, and I've probably fermented 20+ batches with it, so I know this isn't quite normal. My brew process hasn't changed, and I've had typical quick ferments with WLP007 in a recent brew. I just brewed a 1.070 IPA last night, properly rehydrated 1.5 packs of 05, and we're at 20hrs with no signs of fermentation. Just like my last 3 packs of 05, I'm sure it will take off in the next 12hrs or so, and slowly ferment out, I'm not worried but something is off. Ive double checked my fermentation chamber temp probe, it's fine.

Oddly enough, my attenuation is fine, but the yeast is slow to floc. These are all signs of poor yeast health. Anyone else having any issues with US05 lately? My packs expire 05/13.

__________________
scottland is offline
 
Reply With Quote Quick reply to this message
Old 10-26-2011, 01:36 AM   #2
Hammy71
Senior Member
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
Hammy71's Avatar
Recipes 
 
Join Date: Sep 2008
Location: , Maryland, The Tax Me State
Posts: 5,730
Liked 447 Times on 344 Posts
Likes Given: 694

Default

Yes, last two fermentations have been extremely slow and taken a few more weeks to fall out. Beer has been fine, but I have noticed a difference.

__________________
Hammy71 is offline
 
Reply With Quote Quick reply to this message
Old 10-26-2011, 01:40 AM   #3
weirdboy
HBT_LIFETIMESUPPORTER.png
Feedback Score: 4 reviews
Recipes 
 
Join Date: May 2009
Location: Los Angeles
Posts: 7,981
Liked 434 Times on 354 Posts
Likes Given: 63

Default

I'm still pitching my old packets. Haven't noticed any issues with lag time or flocculation on those.

__________________
weirdboy is offline
 
Reply With Quote Quick reply to this message
Old 10-26-2011, 01:40 AM   #4
scottland
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2010
Location: Chandler, AZ
Posts: 2,117
Liked 141 Times on 105 Posts
Likes Given: 12

Default

I hate to say it, but this might get me to switch back to liquid yeast and washing.

__________________
scottland is offline
 
Reply With Quote Quick reply to this message
Old 10-26-2011, 01:53 AM   #5
acuenca
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jul 2011
Location: Gainesville, Fl
Posts: 362
Liked 7 Times on 7 Posts

Default

Just bought a packet on Sat...Do you guys have the lot number? At least what I think is the lot number is the number above the exp date...

__________________
acuenca is offline
 
Reply With Quote Quick reply to this message
Old 10-26-2011, 02:29 AM   #6
beergolf
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
beergolf's Avatar
Recipes 
 
Join Date: Jan 2011
Location: collingswood, nj
Posts: 4,473
Liked 518 Times on 407 Posts
Likes Given: 184

Default

Where are you getting it?

How was it stored?

I have used US-05 a lot and have never had problems. It is a great yeast. That is what leads me to believe that it may be improper storage before you got it.

__________________
beergolf is offline
 
Reply With Quote Quick reply to this message
Old 10-26-2011, 02:43 AM   #7
cooper
Feedback Score: 0 reviews
Recipes 
 
Join Date: Dec 2009
Location: New Baden, IL
Posts: 353
Liked 10 Times on 8 Posts

Default

I just used a pack of US-05 on a batch of pumpkin ale on the 21st that I got from northern brewer and it started up just fine within a few hours. No starter or hydration either. Today is the 25th and it's just started slowing down.

__________________
cooper is offline
 
Reply With Quote Quick reply to this message
Old 10-26-2011, 02:47 AM   #8
bullinachinashop
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2009
Location: NE Ohio
Posts: 1,046
Liked 27 Times on 24 Posts
Likes Given: 31

Default

I wonder if that is why it hasn't been available lately.

Bull

__________________
bullinachinashop is offline
 
Reply With Quote Quick reply to this message
Old 10-26-2011, 02:51 AM   #9
iaefebs
Registered User
HBT_SUPPORTER.png
Feedback Score: 2 reviews
Recipes 
 
Join Date: Aug 2010
Location: West Coast, MI
Posts: 2,663
Liked 242 Times on 176 Posts
Likes Given: 605

Default

This discussion won't go anywhere until you post expiration date. The OP is questioning packs expiring 5/13 not what you see with whatever batch you last used. If you use 05 check the date then post.

__________________
iaefebs is offline
 
Reply With Quote Quick reply to this message
Old 10-26-2011, 02:58 AM   #10
scottland
Feedback Score: 0 reviews
Recipes 
 
Join Date: May 2010
Location: Chandler, AZ
Posts: 2,117
Liked 141 Times on 105 Posts
Likes Given: 12

Default

No, I bought like 6 packs at the same time, all from the same lot, I still have two left. I checked them before I pitched 2 last night. Packs say 71322 124 1659 expires 05/13.

Now for all I know these could have been handled poorly -- they all came from the same shop at the same time. I started this thread to see if anyone else had the same issue(I forgot the ? Mark in the thread title)

There is no need for panic, me beers taste fine, this isn't like the notty issue last year. Its just annoying when what normally is a four day ferment takes fourteen.

__________________
scottland is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Safale s-33 jonmohno Fermentation & Yeast 4 08-06-2011 02:28 AM
Safale US-04 EddieB428 Fermentation & Yeast 9 07-21-2011 04:16 PM
Safale - 05 with a 1.070 OG prjectmayhem Fermentation & Yeast 7 04-30-2011 03:22 PM
(Un)SafAle US-05 Conan Fermentation & Yeast 12 03-09-2011 12:39 PM
Safale US-05 is da man! dmfa200 Fermentation & Yeast 6 09-19-2010 01:44 PM



Newest Threads

LATEST SPONSOR DEALS