Get your HBT Growlers, Shirts and Membership before the Rush!


Home Brew Forums > Home Brewing Beer > Fermentation & Yeast > 1056 & Sulfur?
Reply
 
LinkBack Thread Tools
Old 09-06-2012, 04:43 PM   #1
wiescins
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jun 2010
Location: Chicago, IL
Posts: 231
Liked 4 Times on 4 Posts
Likes Given: 3

Default 1056 & Sulfur?

I recently brewed a PA/IPA I'm not happy with and am trying to figure specifically what I did wrong, there are a number of options.

The batch in question is the 2nd running's of a partigyle brew on 7/4/12. I batch sparge, so the Barleywine was actually 1st & 2nd running's and the PA/IPA was the 3rd & 4th runnings. Doing the partigyle was a last minute idea, yeast was on-sale ($5) and I had a bunch of random american hops.

Fermentables
50/50 Golden Promise & Maris Otter mashed @ 155F + 1lb corn sugar
8gal pre-boil, 5gal @ 1.056 post-boil.

Hops
60min = 0.6oz Summit
20min = 0.5oz Ahtanum, 0.5oz Chinook, 0.5oz Willamette
15min = 0.5oz Cascade
10min = 0.4oz Willamette
5min = 0.5oz Cascade, 0.5oz Chinook
Dry = 1.0oz Centennial, 1.0oz Simcoe (both leaf for 7 days)

Yeast
1056, without starter
Fermented very high, was crazy hot in Chicago and my carboy cooling system is a wet towel the shower. The sticker on the side was mid 70's for active fermentation.
FG is 1.009

I'm getting a sulfury or meaty aroma. My thoughts are either the high fermentation temp or using the 3rd & 4th runnings.

Thoughts?

__________________
wiescins is offline
 
Reply With Quote Quick reply to this message
Old 09-06-2012, 06:45 PM   #2
3sheetsEMJ
Feedback Score: 0 reviews
Recipes 
 
Join Date: Oct 2011
Posts: 196
Liked 3 Times on 3 Posts

Default

Do you mean a sulfur aroma off of the airlocks?I have noticed this in a few of my 1056 batches, but this did not affect the quality (aroma, taste, etc) of the resulting home brew. I mainly experienced this in high temps as well. I wouldn'tworry about it too much unless it is very strong.

__________________
3sheetsEMJ is offline
 
Reply With Quote Quick reply to this message
Old 09-06-2012, 07:16 PM   #3
wiescins
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jun 2010
Location: Chicago, IL
Posts: 231
Liked 4 Times on 4 Posts
Likes Given: 3

Default

Quote:
Originally Posted by 3sheetsEMJ View Post
Do you mean a sulfur aroma off of the airlocks?I have noticed this in a few of my 1056 batches, but this did not affect the quality (aroma, taste, etc) of the resulting home brew. I mainly experienced this in high temps as well. I wouldn'tworry about it too much unless it is very strong.
My issue is actually with the finished beer. She is bottled & carb'd. I noticed the issue at gravity sample (pre-dry hop) and it will a little masked at bottling (post-dry hop), but not it is still lingering.
__________________
wiescins is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
1056 in OG1.078 Jay1 Fermentation & Yeast 10 09-05-2013 01:29 AM
Sulfur Cause Hex23 Fermentation & Yeast 9 01-16-2013 08:45 AM
Irish Ale vs. 1056? rebel80 Fermentation & Yeast 4 02-04-2012 05:53 PM
Stressed out 1056? jclimacus Fermentation & Yeast 3 02-18-2011 03:01 AM
1056 in an ESB?? petep1980 Fermentation & Yeast 4 07-26-2010 07:52 PM



Newest Threads

LATEST SPONSOR DEALS