Electric Brewing Supply 30A BCS Giveaway!


Home Brew Forums > Home Brewing Beer > General Beer Discussion > How is this for bad luck?!?
Reply
 
LinkBack Thread Tools
Old 12-11-2012, 05:27 PM   #1
conneryis007
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2009
Location: Keystone, CO
Posts: 262
Liked 22 Times on 20 Posts
Likes Given: 15

Default How is this for bad luck?!?

Yesterday I was brewing a 10 gallon batch of an imperial black IPA and had 5 minutes to go in the boil. I turned on my pump to recirculate the wort through my plate chiller for the last 5 minutes to sanitize everything. The pump primed and sent liquid out but then dead stopped when it hit the plate chiller. I tried twice and thought oh crap, my plate chiller is clogged, I didn't clean it out well enough the last time I used it! Frantic now, I disassembled the fittings to see if I could blow air through the plate and see inside. While disassembling I found the issue. The silicone check valve from the gas in port of my sanke coupler was perfectly lodged, facing the wrong direction, inside my male side quick release fitting! All of my fittings shared a PBW and then star san bath and some how these two pieces really wanted to be together!

Just thought I would share my need to slow down, or drink less, or pay more attention!

__________________
conneryis007 is offline
 
Reply With Quote Quick reply to this message
Old 12-11-2012, 05:29 PM   #2
inhousebrew
Feedback Score: 0 reviews
Recipes 
 
Join Date: Aug 2012
Location: minneapolis, minnesota
Posts: 1,424
Liked 121 Times on 110 Posts
Likes Given: 36

Default

Was it clogged from poor cleaning or hops? I've had hop issues in the past, not sure what you do to filter them out.

__________________

I hate Walder Frey...

inhousebrew is offline
 
Reply With Quote Quick reply to this message
Old 12-11-2012, 05:35 PM   #3
conneryis007
Feedback Score: 0 reviews
Recipes 
 
Join Date: Nov 2009
Location: Keystone, CO
Posts: 262
Liked 22 Times on 20 Posts
Likes Given: 15

Default

Quote:
Originally Posted by inhousebrew View Post
Was it clogged from poor cleaning or hops? I've had hop issues in the past, not sure what you do to filter them out.
I have a false bottom in my boil kettle so no hops issue for me. See the reason below (from OP):

Quote:
Originally Posted by conneryis007 View Post
While disassembling I found the issue. The silicone check valve from the gas in port of my sanke coupler was perfectly lodged, facing the wrong direction, inside my male side quick release fitting! All of my fittings shared a PBW and then star san bath and some how these two pieces really wanted to be together!
__________________
conneryis007 is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wish me luck..... E-Mursed Bottling/Kegging 2 04-22-2012 10:50 PM
Wish Us Luck sgoehner All Grain & Partial Mash Brewing 10 12-05-2011 05:18 PM
My Luck!!! MJoyner Introductions 12 10-14-2010 12:32 PM
HERE WE GO! First AG. Wish me luck IrregularPulse All Grain & Partial Mash Brewing 20 05-18-2008 07:48 PM