Get your HBT Growlers, Shirts and Membership before the Rush!


Home Brew Forums > Home Brewing Beer > Recipes/Ingredients > WLP410 Low attenuation?
Reply
 
LinkBack Thread Tools
Old 06-29-2009, 03:41 PM   #1
ikelso
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jun 2009
Location: TX
Posts: 44
Default WLP410 Low attenuation?

I'm on my 2nd batch of belgian white with WLP410, the Platinum series of belgian white yeast offered by White Labs. The website says attenuation is 70-75%.

My first batch was an AG concoction that started at 1.046 and ended at just shy of 1.016, Giving attenuation in the 65% range. My current batch (yeast pitched from the cake on the original, mini mash) started at 1.048 and after 7 days in a primary is sitting at 1.018 for only about 61-62% attenuation.

Has anyone else used this yeast and had this same problem? I don't have much hope for my current batch hitting the terminal of 1.010 that I'm shooting for.

Let me know if you've used it and gotten good results. I'm weary of using the yeast I've washed that's in my fridge now until I hear good things about this strain.

__________________
ikelso is offline
 
Reply With Quote Quick reply to this message
Old 06-29-2009, 09:13 PM   #2
MNDan
HBT_LIFETIMESUPPORTER.png
Feedback Score: 0 reviews
Recipes 
 
Join Date: Apr 2009
Location: Minnetonka, MN
Posts: 345
Liked 15 Times on 11 Posts
Likes Given: 8

Default

I just brewed a batch of wit beer with WLP410 and it's finally gotten down to 1.014 from 1.047 after two weeks. I just kegged it, but am going to keep it at room temp for another day or two to see if I can get it down to 1.012. Definitely a slow worker, and this was even with fermenting at 71 degrees. Hopefully the results will make it worth the extra time and trouble.

__________________
MNDan is offline
 
Reply With Quote Quick reply to this message
Old 06-29-2009, 11:42 PM   #3
ikelso
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jun 2009
Location: TX
Posts: 44
Default

Ok, somewhat glad it's not just me. The first batch I checked after 8 days, left it in another 3 days and checked again and it was the same gravity. After racking and waiting another 3 days I checked and it had fallen ever so slightly but not a full point.

I don't have an airstone... wondering if my stirring generated enough oxygen. MNDan, did you oxygenate your wort and still had this slow attenuation?

__________________
ikelso is offline
 
Reply With Quote Quick reply to this message
Old 07-02-2009, 08:46 PM   #4
ikelso
Feedback Score: 0 reviews
Recipes 
 
Join Date: Jun 2009
Location: TX
Posts: 44
Default

Even worse than I thought. I didn't correct the 1.016 reading, it's really 1.018. It hasn't moved much since my original post 3 days ago either. It was sitting right on the 1.016 line rather than just right above 1.016. Taste is a little sweeter than I'd like for this strain too. Oh well, won't go back to buying it, but I'll use the remaining bit in the fridge soon on something off the wall.

__________________
ikelso is offline
 
Reply With Quote Quick reply to this message
Old 07-02-2009, 09:06 PM   #5
Tonedef131
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2008
Location: Fort Wayne
Posts: 1,906
Liked 22 Times on 12 Posts
Likes Given: 3

Default

Yes, I also have been repitching this yeast while trying to perfect my wit. I will be brewing my third batch with it this weekend and both of the previous batches with it finished above 1.015. I doubt I will buy this strain again, I prefer the other wit strain that is offered year round.

__________________
Tonedef131 is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reusing WLP410? carnevoodoo Beginners Beer Brewing Forum 6 06-30-2010 05:32 AM
Is WLP410 the Ommegang house strain? kscomp0 Fermentation & Yeast 5 06-18-2010 03:01 AM
Brewing a Wit: WLP400 vs WLP410 arover Recipes/Ingredients 1 06-09-2009 05:15 AM
Help with Low Attenuation newbrewerny Beginners Beer Brewing Forum 3 10-26-2008 04:11 AM
attenuation???? pa-in-utah General Techniques 4 04-06-2007 01:44 AM



Newest Threads

LATEST SPONSOR DEALS