Happy HolidaySs Giveaway - Last Sponsor Giveaway of the Year!

Come Enter the BrewDeals/FastFerment Giveaway!


Home Brew Forums > Home Brewing Beer > Equipment/Sanitation > March Pump broke on third use WTF!
Reply
 
LinkBack Thread Tools
Old 10-17-2009, 04:08 PM   #1
flananuts
HBT_LIFETIMESUPPORTER.png
Feedback Score: 0 reviews
 
flananuts's Avatar
Recipes 
 
Join Date: Dec 2008
Location: Monmouth County, NJ
Posts: 507
Liked 1 Times on 1 Posts

Default March Pump broke on third use WTF!

I have two march pumps I use in a HERMS system and one was always a bit noisier than the other. This morning as I started up my system for an AG the pump was extra noisy then it starting squealing and screeching and I knew I was F'd. I pulled the pump housing apart and didn't notice any damage to the impeller but I think there might have been a gasket or something where the impeller shaft sits in the top of the polysulphone head. I put it back together and could not get the pump to prime and then the screeching noise came back.

Has anyone had this problem before? Has anyone pulled the head apart before. Are there other parts that are missing? I bought this from Northern Brewer so hopefully I can get it exchanged.

__________________
flananuts is offline
 
Reply With Quote Quick reply to this message
Old 10-17-2009, 04:49 PM   #2
Bobby_M
Vendor and Brewer
HBT_SPONSOR.png
Vendor Ads 
Feedback Score: 2 reviews
 
Bobby_M's Avatar
Recipes 
 
Join Date: Aug 2006
Location: Whitehouse Station, NJ
Posts: 22,197
Liked 1042 Times on 696 Posts
Likes Given: 28

Default

That sound is what happens if you run it completely dry. Have you tried forcing water into the pump head with a garden hose first?

__________________
BrewHardware.com has a new website. Please check it out and let me know what you think!
New 100% Stainless Steel Heating Elements are IN!
Chugger Pumps, Pump Kits, Camlocks, Sightglasses, Clear USA made Silicone Tubing, RIMS, Electric Install Parts, etc. Did you know we are also now a full service homebrew shop selling malt, hops, yeast (Wyeast), etc?
Bobby_M is offline
 
Reply With Quote Quick reply to this message
Old 10-17-2009, 05:09 PM   #3
The Pol
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2007
Posts: 11,768
Liked 73 Times on 63 Posts
Likes Given: 14

Default

As Bobby said.. the squealing is typically heard when the impeller is turning dry. If the noise is not the motor, but is the impeller, Id pull apart the compartment where the impeller resides ansd look to see if there is anything noticeable.

But of course you have done this already... man, I dunno

__________________
The Pol is offline
 
Reply With Quote Quick reply to this message
Old 10-17-2009, 05:38 PM   #4
flananuts
HBT_LIFETIMESUPPORTER.png
Feedback Score: 0 reviews
 
flananuts's Avatar
Recipes 
 
Join Date: Dec 2008
Location: Monmouth County, NJ
Posts: 507
Liked 1 Times on 1 Posts

Default

Thanks, I did that and found that the thrust washer is completely missing. This happened while the pump was circulating water, fortunately not mash. I guess the rattling noise I heard before the squeal was the washer being chewed up. I'm going to call March on Monday and see if I can get some replacement parts from them.

__________________
flananuts is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why won't my March pump march? wildwest450 Equipment/Sanitation 12 10-09-2011 05:01 PM
How high can a March Pump--pump? jlosbor Equipment/Sanitation 18 07-02-2010 04:13 PM
March Pump Set Up Gammon N Beer Equipment/Sanitation 4 05-28-2009 09:03 PM
March pump Dwain Equipment/Sanitation 14 04-22-2009 09:56 PM
Which March pump to use? skifast1 Equipment/Sanitation 2 03-13-2007 03:52 PM



Newest Threads

LATEST SPONSOR DEALS