New Giveaway - Wort Monster Conical Fermenter!

Home Brew Forums > Home Brewing Beer > Equipment/Sanitation > March Pump broke on third use WTF!




Reply
 
LinkBack Thread Tools Display Modes
Old 10-17-2009, 03:08 PM   #1
flananuts
HBT_LIFETIMESUPPORTER.png
Feedback Score: 0 reviews
 
flananuts's Avatar
Recipes 
 
Join Date: Dec 2008
Location: Monmouth County, NJ
Posts: 506
Liked 1 Times on 1 Posts

Default March Pump broke on third use WTF!

I have two march pumps I use in a HERMS system and one was always a bit noisier than the other. This morning as I started up my system for an AG the pump was extra noisy then it starting squealing and screeching and I knew I was F'd. I pulled the pump housing apart and didn't notice any damage to the impeller but I think there might have been a gasket or something where the impeller shaft sits in the top of the polysulphone head. I put it back together and could not get the pump to prime and then the screeching noise came back.

Has anyone had this problem before? Has anyone pulled the head apart before. Are there other parts that are missing? I bought this from Northern Brewer so hopefully I can get it exchanged.



__________________
flananuts is offline
 
Reply With Quote Quick reply to this message
Old 10-17-2009, 03:49 PM   #2
Bobby_M
Vendor and Brewer
HBT_SPONSOR.png
Vendor Ads 
Feedback Score: 1 reviews
 
Bobby_M's Avatar
Recipes 
 
Join Date: Aug 2006
Location: Piscataway, NJ
Posts: 21,734
Liked 853 Times on 572 Posts
Likes Given: 26

Default

That sound is what happens if you run it completely dry. Have you tried forcing water into the pump head with a garden hose first?



__________________
BrewHardware.com
Sightglass, Refractometer, Ball Valve, Weldless bulkhead, Thermometer, Decals, Stainless Steel Fittings, Compression Fittings, Camlock Quick Disconnects, Scale, RIMS tube, Plate Chiller, Chugger Pump, Super Clear Silicone Tubing, and more!
Bobby_M is offline
 
Reply With Quote Quick reply to this message
Old 10-17-2009, 04:09 PM   #3
The Pol
Feedback Score: 0 reviews
Recipes 
 
Join Date: Feb 2007
Posts: 11,616
Liked 49 Times on 46 Posts

Default

As Bobby said.. the squealing is typically heard when the impeller is turning dry. If the noise is not the motor, but is the impeller, Id pull apart the compartment where the impeller resides ansd look to see if there is anything noticeable.

But of course you have done this already... man, I dunno

__________________
The Pol is offline
 
Reply With Quote Quick reply to this message
Old 10-17-2009, 04:38 PM   #4
flananuts
HBT_LIFETIMESUPPORTER.png
Feedback Score: 0 reviews
 
flananuts's Avatar
Recipes 
 
Join Date: Dec 2008
Location: Monmouth County, NJ
Posts: 506
Liked 1 Times on 1 Posts

Default

Thanks, I did that and found that the thrust washer is completely missing. This happened while the pump was circulating water, fortunately not mash. I guess the rattling noise I heard before the squeal was the washer being chewed up. I'm going to call March on Monday and see if I can get some replacement parts from them.

__________________
flananuts is offline
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options
Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why won't my March pump march? wildwest450 Equipment/Sanitation 12 10-09-2011 04:01 PM
How high can a March Pump--pump? jlosbor Equipment/Sanitation 18 07-02-2010 03:13 PM
March Pump Set Up Gammon N Beer Equipment/Sanitation 4 05-28-2009 08:03 PM
March pump Dwain Equipment/Sanitation 14 04-22-2009 08:56 PM
Which March pump to use? skifast1 Equipment/Sanitation 2 03-13-2007 02:52 PM