Happy HolidaySs Giveaway - Last Sponsor Giveaway of the Year!

Come Enter the BrewDeals/FastFerment Giveaway!


Home Brew Forums > Home Brewing Beer > Equipment/Sanitation > March 809 HS Problem
Reply
 
LinkBack Thread Tools
Old 02-07-2013, 08:39 PM   #11
TwoDogBrew
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
TwoDogBrew's Avatar
Recipes 
 
Join Date: Jun 2012
Location: Raleigh, NC
Posts: 151
Liked 11 Times on 11 Posts
Likes Given: 27

Default

Quote:
Originally Posted by WalterAtMarchPump View Post
cajeffus, if the thrust washer is not there then the impeller can come in contac with the front housing and cause issues...even the screetching noise can sometimes be heard too....you can try a stainless washer from a hardware store in the mean time...just make sure it has a 1/4" hole to fit over the shaft....and it should cure the issues till the thrust washers arrive for you...


TwoDogBrew, Can you post a pic of your setup or maybe email it to me? I can see if theres anything you may need to change on the setup to help you...
Walter.. Look at the last two in the album
https://plus.google.com/photos/10842...37514564241345

Thanks
Jim
__________________
TwoDogBrew is offline
 
Reply With Quote Quick reply to this message
Old 02-07-2013, 08:43 PM   #12
WalterAtMarchPump
Sponsor
HBT_SPONSOR.png
Vendor Ads 
Feedback Score: 0 reviews
 
WalterAtMarchPump's Avatar
Recipes 
 
Join Date: Dec 2010
Location: Glenview, IL
Posts: 677
Liked 40 Times on 32 Posts
Likes Given: 12

Default

the shaft sticking up farther wouldnt have any issues...it may be it just wasnt pressed far enough into the housing. From the looks of it you have both pump set up/orriented the exact same way....do you have any difference in plumbing between the two? like extra elbows/fittings etc?

__________________

-Walter

WalterAtMarchPump is offline
 
Reply With Quote Quick reply to this message
Old 02-07-2013, 09:00 PM   #13
TwoDogBrew
HBT_SUPPORTER.png
Feedback Score: 0 reviews
 
TwoDogBrew's Avatar
Recipes 
 
Join Date: Jun 2012
Location: Raleigh, NC
Posts: 151
Liked 11 Times on 11 Posts
Likes Given: 27

Default

Quote:
Originally Posted by WalterAtMarchPump View Post
the shaft sticking up farther wouldnt have any issues...it may be it just wasnt pressed far enough into the housing. From the looks of it you have both pump set up/orriented the exact same way....do you have any difference in plumbing between the two? like extra elbows/fittings etc?
Since they get hooked up with 1/2" silicone tubing and 5/8" barb to QDs they are plumbed identical.. The only difference I would see is the head pressure.. The pump that is fine has more head having to push through 50' of 1/2 copper , more tubing and back to MLT.
The one giving issue is one I recirculate HLT water or recirculate wort to whirlpool.
__________________
TwoDogBrew is offline
 
Reply With Quote Quick reply to this message
Reply



Quick Reply
Message:
Options
Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
MArch 809 Problem - Losing Prime Cape Brewing Equipment/Sanitation 18 06-23-2011 10:18 PM
Major problem with march pump. AshtrayDinner Equipment/Sanitation 15 08-05-2009 04:23 AM
Problem with my march pump... lesyphon Equipment/Sanitation 10 06-19-2009 03:35 AM
March pump problem baer19d Equipment/Sanitation 20 05-26-2009 09:53 PM
March Pump Problem davidkrau Equipment/Sanitation 1 11-23-2007 01:45 AM



Newest Threads

LATEST SPONSOR DEALS